summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-08-12 17:59:27 +0200
committerKarel Kočí <cynerd@email.cz>2018-08-12 18:01:14 +0200
commit588975f959edf6eaae917963d12d2a73fee843b5 (patch)
tree3a4b6eabbe0b12d8afe6836dbd827903386602ca
downloadalpine-personal-pkgs-588975f959edf6eaae917963d12d2a73fee843b5.tar.gz
alpine-personal-pkgs-588975f959edf6eaae917963d12d2a73fee843b5.tar.bz2
alpine-personal-pkgs-588975f959edf6eaae917963d12d2a73fee843b5.zip
Add initial package (shellrc)
-rw-r--r--.gitignore16
-rw-r--r--shellrc/APKBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..9313b04
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,16 @@
+*.apk
+*.gz
+*.tgz
+*.bz2
+*.tbz2
+*.zip
+*.tags
+*.xz
+*.part
+*.tar
+src
+pkg
+pkg-*
+build.log
+core
+!core/
diff --git a/shellrc/APKBUILD b/shellrc/APKBUILD
new file mode 100644
index 0000000..27de58b
--- /dev/null
+++ b/shellrc/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Karel Kočí <cynerd@email.cz>
+# Maintainer: Karel Kočí <cynerd@email.cz>
+pkgname=shellrc
+pkgver=0.5.1
+pkgrel=0
+pkgdesc="Shell initialization files"
+url="https://git.cynerd.cz/shellrc/"
+arch="all"
+license="GPL-3.0+"
+subpackages="$pkgname-zsh $pkgname-bash"
+source="https://git.cynerd.cz/shellrc/snapshot/$pkgname-$pkgver.tar.gz"
+options="!check"
+
+package() {
+ "$builddir/install" --prefix "$pkgdir"
+}
+
+zsh() {
+ depends="zsh"
+ "$builddir/install" --prefix "$pkgdir" --zsh --no-base
+}
+
+bash() {
+ depends="bash"
+ "$builddir/install" --prefix "$pkgdir" --bash --no-base
+}
+
+sha512sums="abcf8aec41e8d3334e120c6defa12bcb4481f8c96066a6a8d7190db27808a3165486d9d6d029d531202dc4fc85bbdca228fbbd93636679caf6b5565c75928495 shellrc-0.4.1.tar.gz"