summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2020-02-20 16:58:02 +0100
committerKarel Kočí <karel.koci@nic.cz>2020-02-20 17:01:23 +0100
commit3b7f2b48135c34323914680816deb4450f0b4aec (patch)
tree2394a2b7cec5c8c70e82eebe62f268cf9f23faf4
parentcb205d95f90e471d3d40d761d6c7fd8690b68d85 (diff)
downloadalpine-personal-pkgs-3b7f2b48135c34323914680816deb4450f0b4aec.tar.gz
alpine-personal-pkgs-3b7f2b48135c34323914680816deb4450f0b4aec.tar.bz2
alpine-personal-pkgs-3b7f2b48135c34323914680816deb4450f0b4aec.zip
ffmpeg-rpi: drop patch as it might be breaking symver of library
-rw-r--r--ffmpeg-rpi/0001-libavutil-clean-up-unused-FF_SYMVER-macro.patch55
-rw-r--r--ffmpeg-rpi/APKBUILD18
2 files changed, 6 insertions, 67 deletions
diff --git a/ffmpeg-rpi/0001-libavutil-clean-up-unused-FF_SYMVER-macro.patch b/ffmpeg-rpi/0001-libavutil-clean-up-unused-FF_SYMVER-macro.patch
deleted file mode 100644
index 9cc6fdf..0000000
--- a/ffmpeg-rpi/0001-libavutil-clean-up-unused-FF_SYMVER-macro.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From ab11be0becb90542f10d5713659b559842c53af2 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Tue, 29 Mar 2016 15:15:17 +0200
-Subject: [PATCH] libavutil: clean up unused FF_SYMVER macro
-
-There is nothing using it since commit d63443b9 (lavc: drop the
-av_fast_{re,m}alloc compatibility wrappers).
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- libavutil/internal.h | 28 ----------------------------
- 1 file changed, 28 deletions(-)
-
-diff --git a/libavutil/internal.h b/libavutil/internal.h
-index 61784b5..69d63d5 100644
---- a/libavutil/internal.h
-+++ b/libavutil/internal.h
-@@ -187,34 +187,6 @@
- #endif
-
- /**
-- * Define a function with only the non-default version specified.
-- *
-- * On systems with ELF shared libraries, all symbols exported from
-- * FFmpeg libraries are tagged with the name and major version of the
-- * library to which they belong. If a function is moved from one
-- * library to another, a wrapper must be retained in the original
-- * location to preserve binary compatibility.
-- *
-- * Functions defined with this macro will never be used to resolve
-- * symbols by the build-time linker.
-- *
-- * @param type return type of function
-- * @param name name of function
-- * @param args argument list of function
-- * @param ver version tag to assign function
-- */
--#if HAVE_SYMVER_ASM_LABEL
--# define FF_SYMVER(type, name, args, ver) \
-- type ff_##name args __asm__ (EXTERN_PREFIX #name "@" ver); \
-- type ff_##name args
--#elif HAVE_SYMVER_GNU_ASM
--# define FF_SYMVER(type, name, args, ver) \
-- __asm__ (".symver ff_" #name "," EXTERN_PREFIX #name "@" ver); \
-- type ff_##name args; \
-- type ff_##name args
--#endif
--
--/**
- * Return NULL if a threading library has not been enabled.
- * Used to disable threading functions in AVCodec definitions
- * when not needed.
---
-2.7.4
-
diff --git a/ffmpeg-rpi/APKBUILD b/ffmpeg-rpi/APKBUILD
index ad9e248..a0194dc 100644
--- a/ffmpeg-rpi/APKBUILD
+++ b/ffmpeg-rpi/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Karel Kočí <cynerd@email.cz>
pkgname=ffmpeg-rpi
pkgver=4.2.2
-pkgrel=5
+pkgrel=6
pkgdesc="Complete and free Internet live audio and video broadcasting solution for Linux/Unix - Raspberry Pi"
url="https://ffmpeg.org/"
arch="armhf armv7 aarch64"
@@ -19,8 +19,6 @@ makedepends="
libass-dev
libssh-dev
libtheora-dev
- libva-dev
- libvdpau-dev
libvorbis-dev
libvpx-dev
libxfixes-dev
@@ -35,9 +33,7 @@ makedepends="
yasm
zlib-dev
"
-source="https://ffmpeg.org/releases/ffmpeg-$pkgver.tar.xz
- 0001-libavutil-clean-up-unused-FF_SYMVER-macro.patch
- "
+source="https://ffmpeg.org/releases/ffmpeg-$pkgver.tar.xz"
# add support for AV1 codec for all archies except armhf and armv7
# as aom is not available on them
@@ -59,7 +55,6 @@ build() {
./configure \
--prefix=/usr \
- --enable-symver \
--target-os=linux \
--enable-avresample \
--enable-avfilter \
@@ -80,12 +75,12 @@ build() {
--enable-shared \
--enable-libxcb \
--enable-libssh \
+ --enable-libopus \
--disable-stripping \
--disable-static \
--disable-librtmp \
- --enable-vaapi \
- --enable-vdpau \
- --enable-libopus \
+ --disable-vaapi \
+ --disable-vdpau \
--enable-omx \
--enable-omx-rpi \
--enable-mmal \
@@ -104,5 +99,4 @@ package() {
# strip --strip-debug "$pkgdir"/usr/lib/*.a
}
-sha512sums="381cd6732fa699eb89000621cf34256920596ed1f9de3c2194dbad35fdf2165269eb7d3a147a0eb75dc18fbb6d601382b5801750e09fc63547766842f84208e3 ffmpeg-4.2.2.tar.xz
-1047a23eda51b576ac200d5106a1cd318d1d5291643b3a69e025c0a7b6f3dbc9f6eb0e1e6faa231b7e38c8dd4e49a54f7431f87a93664da35825cc2e9e8aedf4 0001-libavutil-clean-up-unused-FF_SYMVER-macro.patch"
+sha512sums="381cd6732fa699eb89000621cf34256920596ed1f9de3c2194dbad35fdf2165269eb7d3a147a0eb75dc18fbb6d601382b5801750e09fc63547766842f84208e3 ffmpeg-4.2.2.tar.xz"