summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-02-14 00:50:50 +0100
committerKarel Kočí <cynerd@email.cz>2019-02-14 00:53:13 +0100
commitfb3d65bf92084ce62173c6c83365445d42efc043 (patch)
tree0c0f3ccab6e48dcf3428ee80f44cfdac5a4aff97
parent18822acbe35ce68608d59358031b859891d71678 (diff)
downloadopenwrt-personal-pkgs-fb3d65bf92084ce62173c6c83365445d42efc043.tar.gz
openwrt-personal-pkgs-fb3d65bf92084ce62173c6c83365445d42efc043.tar.bz2
openwrt-personal-pkgs-fb3d65bf92084ce62173c6c83365445d42efc043.zip
bigclown: fix not included binaries
-rw-r--r--bigclown-gateway/Makefile3
-rw-r--r--bigclown-mqtt2influxdb/Makefile3
2 files changed, 6 insertions, 0 deletions
diff --git a/bigclown-gateway/Makefile b/bigclown-gateway/Makefile
index c992a0b..f269f52 100644
--- a/bigclown-gateway/Makefile
+++ b/bigclown-gateway/Makefile
@@ -27,6 +27,9 @@ define Package/$(PKG_NAME)
endef
define Py3Package/$(PKG_NAME)/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_CONF) ./files/config $(1)/etc/config/bigclown-gateway
$(INSTALL_DIR) $(1)/etc/init.d
diff --git a/bigclown-mqtt2influxdb/Makefile b/bigclown-mqtt2influxdb/Makefile
index ea1fdba..87ae66e 100644
--- a/bigclown-mqtt2influxdb/Makefile
+++ b/bigclown-mqtt2influxdb/Makefile
@@ -27,6 +27,9 @@ define Package/$(PKG_NAME)
endef
define Py3Package/$(PKG_NAME)/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/init $(1)/etc/init.d/bigclown-mqtt2influxdb
$(INSTALL_DATA) ./files/config.yml $(1)/etc/bigclown-mqtt2influxdb.yml