summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-08-30 12:42:30 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-08-30 12:52:23 +0200
commit7a4e7809358548e24a5debb375e6e6a368247f79 (patch)
treeb457ae7ba1461966683b28f1f65191443236ee5b
parenta6abd46888c5780377786b50e7a1ca8812ab0960 (diff)
downloadopenwrt-personal-pkgs-7a4e7809358548e24a5debb375e6e6a368247f79.tar.gz
openwrt-personal-pkgs-7a4e7809358548e24a5debb375e6e6a368247f79.tar.bz2
openwrt-personal-pkgs-7a4e7809358548e24a5debb375e6e6a368247f79.zip
autopkg: move it back
-rw-r--r--autopkg-branch.mk (renamed from personal-pkgs-repo/files/autopkg-branch.mk)4
-rw-r--r--autopkg-head.mk (renamed from personal-pkgs-repo/files/autopkg-head.mk)0
-rw-r--r--autopkg-tag.mk (renamed from personal-pkgs-repo/files/autopkg-tag.mk)4
-rw-r--r--autopkg-tail.mk (renamed from personal-pkgs-repo/files/autopkg-tail.mk)0
-rw-r--r--shellrc/Makefile2
-rw-r--r--updater-ng/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/personal-pkgs-repo/files/autopkg-branch.mk b/autopkg-branch.mk
index c8791cc..9b587b3 100644
--- a/personal-pkgs-repo/files/autopkg-branch.mk
+++ b/autopkg-branch.mk
@@ -1,6 +1,6 @@
# Autopkg tracking given branch
AUTOPKG_VARIANT:=branch
-$(call include_mk, autopkg-head.mk)
+include $(TOPDIR)/feeds/personal/autopkg-head.mk
ifndef PKG_SOURCE_BRANCH
$(error You have to define PKG_SOURCE_BRANCH before pkgauto.mk include)
@@ -21,4 +21,4 @@ PKG_RELEASE:=$(shell git $(GIT_ARGS) rev-list --count "$(PKG_VERSION)..$(PKG_SOU
PKG_VERSION:=$(PKG_VERSION:v%=%).9999
endif
-$(call include_mk, autopkg-tail.mk)
+include $(TOPDIR)/feeds/personal/autopkg-tail.mk
diff --git a/personal-pkgs-repo/files/autopkg-head.mk b/autopkg-head.mk
index 115e1ae..115e1ae 100644
--- a/personal-pkgs-repo/files/autopkg-head.mk
+++ b/autopkg-head.mk
diff --git a/personal-pkgs-repo/files/autopkg-tag.mk b/autopkg-tag.mk
index 077c7ad..1524e2c 100644
--- a/personal-pkgs-repo/files/autopkg-tag.mk
+++ b/autopkg-tag.mk
@@ -1,8 +1,8 @@
# Autopkg tracking latest version tag
AUTOPKG_VARIANT:=tag
-$(call include_mk, autopkg-head.mk)
+include $(TOPDIR)/feeds/personal/autopkg-head.mk
PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) tag | grep '^v' | sort | tail -1)
PKG_VERSION:=$(subst v%,%,$(PKG_SOURCE_VERSION))
-$(call include_mk, autopkg-tail.mk)
+include $(TOPDIR)/feeds/personal/autopkg-tail.mk
diff --git a/personal-pkgs-repo/files/autopkg-tail.mk b/autopkg-tail.mk
index 3b6d104..3b6d104 100644
--- a/personal-pkgs-repo/files/autopkg-tail.mk
+++ b/autopkg-tail.mk
diff --git a/shellrc/Makefile b/shellrc/Makefile
index 618343e..1c6c5fd 100644
--- a/shellrc/Makefile
+++ b/shellrc/Makefile
@@ -12,7 +12,7 @@ PKG_RELEASE:=1
PKG_SOURCE_URL:=https://git.cynerd.cz/shellrc
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-$(call include_mk, autopkg-tag.mk)
+include $(TOPDIR)/feeds/personal/autopkg-tag.mk
include $(INCLUDE_DIR)/package.mk
define Package/$(PKG_NAME)
diff --git a/updater-ng/Makefile b/updater-ng/Makefile
index 5fba9a6..17b8020 100644
--- a/updater-ng/Makefile
+++ b/updater-ng/Makefile
@@ -14,7 +14,7 @@ PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
HOST_BUILD_DEPENDS:=curl/host libevent2/host lua/host
PKG_BUILD_DEPENDS:=busybox
-$(call include_mk, autopkg-branch.mk)
+include $(TOPDIR)/feeds/personal/autopkg-branch.mk
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
include $(TOPDIR)/feeds/packages/lang/python/python-package.mk