summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-10-31 21:21:13 +0100
committerKarel Kočí <cynerd@email.cz>2018-10-31 21:21:13 +0100
commit24d990f9bb9401952bd30619fe5b723019f14e78 (patch)
treef8f895ca072454b8dcc35d34fbbc0987d3b3d5c4
parentd093b44a67e7359de34a936454e977fa190bfb82 (diff)
downloadopenwrt-personal-pkgs-24d990f9bb9401952bd30619fe5b723019f14e78.tar.gz
openwrt-personal-pkgs-24d990f9bb9401952bd30619fe5b723019f14e78.tar.bz2
openwrt-personal-pkgs-24d990f9bb9401952bd30619fe5b723019f14e78.zip
autopkg: add possibility to consider all tags
-rw-r--r--autopkg-tag.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/autopkg-tag.mk b/autopkg-tag.mk
index 9b80418..5c7bb28 100644
--- a/autopkg-tag.mk
+++ b/autopkg-tag.mk
@@ -2,7 +2,12 @@
AUTOPKG_VARIANT:=tag
include $(TOPDIR)/feeds/personal/autopkg-head.mk
+ifeq ($(PKG_SOURCE_ALL_TAGS),y)
+PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) tag | sort -V | tail -1)
+PKG_VERSION:=$(PKG_SOURCE_VERSION)
+else
PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) tag | grep '^v' | sort -V | tail -1)
PKG_VERSION:=$(subst v%,%,$(PKG_SOURCE_VERSION))
+endif
include $(TOPDIR)/feeds/personal/autopkg-tail.mk