summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-03-11 21:28:28 +0100
committerKarel Kočí <cynerd@email.cz>2019-03-11 21:28:28 +0100
commit01592b391394c87e39b1f41d6437f06ce831ec23 (patch)
tree034c27f4a86009581c0fc185e88b6928c4bc984c
parent70adb60173e18c5e02c6e604b0451a672ec2e4c1 (diff)
downloadopenwrt-personal-pkgs-01592b391394c87e39b1f41d6437f06ce831ec23.tar.gz
openwrt-personal-pkgs-01592b391394c87e39b1f41d6437f06ce831ec23.tar.bz2
openwrt-personal-pkgs-01592b391394c87e39b1f41d6437f06ce831ec23.zip
Drop python packages that are now in upstream
-rw-r--r--click-log/Makefile34
-rw-r--r--python-appdirs/Makefile36
-rw-r--r--python-chardet/Makefile36
-rw-r--r--python-contextlib2/Makefile35
-rw-r--r--python-decorator/Makefile31
-rw-r--r--python-influxdb/Makefile36
-rw-r--r--python-jsonpath-ng/Makefile31
-rw-r--r--python-schema/Makefile35
8 files changed, 0 insertions, 274 deletions
diff --git a/click-log/Makefile b/click-log/Makefile
deleted file mode 100644
index 9d4de05..0000000
--- a/click-log/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=click-log
-PKG_VERSION:=0.3.2
-PKG_RELEASE:=1
-
-PKG_SOURCE_URL:=https://codeload.github.com/click-contrib/click-log/tar.gz/$(PKG_VERSION)?
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=16babb66a2ebf22c37c1cf38753a84e6027eb8991fcf9a8487971591b8ca9812
-PKG_LICENSE:=MIT
-
-include $(INCLUDE_DIR)/package.mk
-include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
-
-define Package/python3-click-log
- SECTION:=lang
- CATEGORY:=Languages
- SUBMENU:=Python
- URL:=http://github.com/mitsuhiko/click
- TITLE:=python3-click-log
- DEPENDS:=+python3-click
- VARIANT:=python3
-endef
-
-define Package/python3-click-log/description
- Simple and beautiful logging for click applications
-endef
-
-$(eval $(call Py3Package,python3-click-log))
-$(eval $(call BuildPackage,python3-click-log))
diff --git a/python-appdirs/Makefile b/python-appdirs/Makefile
deleted file mode 100644
index 7b5edbe..0000000
--- a/python-appdirs/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python-appdirs
-PKG_VERSION:=1.4.3
-PKG_RELEASE:=1
-
-PKG_SOURCE_URL:=https://pypi.python.org/packages/source/a/appdirs/
-PKG_SOURCE:=appdirs-$(PKG_VERSION).tar.gz
-PKG_HASH:=9e5896d1372858f8dd3344faf4e5014d21849c756c8d5701f78f8a103b372d92
-PKG_LICENSE:=MIT
-PKG_BUILD_DIR:=$(BUILD_DIR)/appdirs-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
-
-define Package/python3-appdirs
- SECTION:=lang
- CATEGORY:=Languages
- SUBMENU:=Python
- URL:=https://github.com/ActiveState/appdirs
- TITLE:=python3-appdirs
- DEPENDS:=+python3-light
- VARIANT:=python3
-endef
-
-define Package/python-appdirs/description
- The Universal Character Encoding Detector
-endef
-
-$(eval $(call Py3Package,python3-appdirs))
-$(eval $(call BuildPackage,python3-appdirs))
-$(eval $(call BuildPackage,python3-appdirs-src))
diff --git a/python-chardet/Makefile b/python-chardet/Makefile
deleted file mode 100644
index aaca644..0000000
--- a/python-chardet/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python-chardet
-PKG_VERSION:=3.0.4
-PKG_RELEASE:=1
-
-PKG_SOURCE_URL:=https://pypi.python.org/packages/source/c/chardet/
-PKG_SOURCE:=chardet-$(PKG_VERSION).tar.gz
-PKG_HASH:=84ab92ed1c4d4f16916e05906b6b75a6c0fb5db821cc65e70cbd64a3e2a5eaae
-PKG_LICENSE:=GPLv2.1
-PKG_BUILD_DIR:=$(BUILD_DIR)/chardet-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
-
-define Package/python3-chardet
- SECTION:=lang
- CATEGORY:=Languages
- SUBMENU:=Python
- URL:=https://github.com/chardet/chardet
- TITLE:=python3-chardet
- DEPENDS:=+python3-light
- VARIANT:=python3
-endef
-
-define Package/python-chardet/description
- The Universal Character Encoding Detector
-endef
-
-$(eval $(call Py3Package,python3-chardet))
-$(eval $(call BuildPackage,python3-chardet))
-$(eval $(call BuildPackage,python3-chardet-src))
diff --git a/python-contextlib2/Makefile b/python-contextlib2/Makefile
deleted file mode 100644
index 36b8b8d..0000000
--- a/python-contextlib2/Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python-contextlib2
-PKG_VERSION:=0.5.5
-PKG_RELEASE:=1
-
-PKG_SOURCE_URL:=https://pypi.python.org/packages/source/c/contextlib2/
-PKG_SOURCE:=contextlib2-$(PKG_VERSION).tar.gz
-PKG_HASH:=509f9419ee91cdd00ba34443217d5ca51f5a364a404e1dce9e8979cea969ca48
-PKG_BUILD_DIR:=$(BUILD_DIR)/contextlib2-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
-
-define Package/python3-contextlib2
- SECTION:=lang
- CATEGORY:=Languages
- SUBMENU:=Python
- URL:=http://contextlib2.readthedocs.org
- TITLE:=python3-contextlib2
- DEPENDS:=+python3-light
- VARIANT:=python3
-endef
-
-define Package/python-contextlib2/description
- contextlib2 is a backport of the standard library’s contextlib module to earlier Python versions.
-endef
-
-$(eval $(call Py3Package,python3-contextlib2))
-$(eval $(call BuildPackage,python3-contextlib2))
-$(eval $(call BuildPackage,python3-contextlib2-src))
diff --git a/python-decorator/Makefile b/python-decorator/Makefile
deleted file mode 100644
index 4fcff82..0000000
--- a/python-decorator/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python-decorator
-PKG_VERSION:=4.3.2
-PKG_RELEASE:=1
-
-PKG_SOURCE_URL:=https://codeload.github.com/micheles/decorator/tar.gz/$(PKG_VERSION)?
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=c053ec881270608a5aef624a45a7700ec76ceca9d96689506411e1f319085380
-PKG_BUILD_DIR:=$(BUILD_DIR)/decorator-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
-
-define Package/python3-decorator
- SECTION:=lang
- CATEGORY:=Languages
- SUBMENU:=Python
- URL:=https://github.com/micheles/decorator
- TITLE:=python3-decodator
- DEPENDS:=+python3-light
- VARIANT:=python3
-endef
-
-$(eval $(call Py3Package,python3-decorator))
-$(eval $(call BuildPackage,python3-decorator))
-$(eval $(call BuildPackage,python3-decorator-src))
diff --git a/python-influxdb/Makefile b/python-influxdb/Makefile
deleted file mode 100644
index db11e54..0000000
--- a/python-influxdb/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python-influxdb
-PKG_VERSION:=5.2.1
-PKG_RELEASE:=1
-
-PKG_SOURCE_URL:=https://pypi.python.org/packages/source/i/influxdb/
-PKG_SOURCE:=influxdb-$(PKG_VERSION).tar.gz
-PKG_HASH:=75d96de25d0d4e9e66e155f64dc9dc2a48de74ac4e77e3a46ad881fba772e3b6
-PKG_LICENSE:=MIT
-PKG_BUILD_DIR:=$(BUILD_DIR)/influxdb-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
-
-define Package/python3-influxdb
- SECTION:=lang
- CATEGORY:=Languages
- SUBMENU:=Python
- URL:=https://github.com/influxdb/influxdb-python
- TITLE:=python3-influxdb
- DEPENDS:=+python3-requests +python3-pytz +python3-six +python3-dateutil
- VARIANT:=python3
-endef
-
-define Package/python3-influxdb/description
- Python client for InfluxDB
-endef
-
-$(eval $(call Py3Package,python3-influxdb))
-$(eval $(call BuildPackage,python3-influxdb))
-$(eval $(call BuildPackage,python3-influxdb-src))
diff --git a/python-jsonpath-ng/Makefile b/python-jsonpath-ng/Makefile
deleted file mode 100644
index 90a6378..0000000
--- a/python-jsonpath-ng/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python-jsonpath-ng
-PKG_VERSION:=1.4.3
-PKG_RELEASE:=1
-
-PKG_SOURCE_URL:=https://pypi.python.org/packages/source/j/jsonpath-ng/
-PKG_SOURCE:=jsonpath-ng-$(PKG_VERSION).tar.gz
-PKG_HASH:=b1fc75b877e9b2f46845a455fbdcfb0f0d9c727c45c19a745d02db620a9ef0be
-PKG_BUILD_DIR:=$(BUILD_DIR)/jsonpath-ng-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
-
-define Package/python3-jsonpath-ng
- SECTION:=lang
- CATEGORY:=Languages
- SUBMENU:=Python
- URL:=https://github.com/h2non/jsonpath-ng
- TITLE:=python3-jsonpath-ng
- DEPENDS:=+python3-ply +python3-six +python3-decorator
- VARIANT:=python3
-endef
-
-$(eval $(call Py3Package,python3-jsonpath-ng))
-$(eval $(call BuildPackage,python3-jsonpath-ng))
-$(eval $(call BuildPackage,python3-jsonpath-ng-src))
diff --git a/python-schema/Makefile b/python-schema/Makefile
deleted file mode 100644
index 01e28c9..0000000
--- a/python-schema/Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python-schema
-PKG_VERSION:=0.7.0
-PKG_RELEASE:=1
-
-PKG_SOURCE_URL:=https://codeload.github.com/keleshev/schema/tar.gz/v$(PKG_VERSION)?
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=6c6da2154c0f63025127a1ecb3b2f07b95ec8dd029663fc74ab2e972bf770c72
-PKG_BUILD_DIR:=$(BUILD_DIR)/schema-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
-
-define Package/python3-schema
- SECTION:=lang
- CATEGORY:=Languages
- SUBMENU:=Python
- URL:=https://github.com/keleshev/schema
- TITLE:=python3-schema
- DEPENDS:=+python3-light +python3-contextlib2
- VARIANT:=python3
-endef
-
-define Package/python3-schema/description
- Schema validation just got Pythonic
-endef
-
-$(eval $(call Py3Package,python3-schema))
-$(eval $(call BuildPackage,python3-schema))
-$(eval $(call BuildPackage,python3-schema-src))