summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-04-04 13:15:59 +0200
committerKarel Kočí <cynerd@email.cz>2017-04-04 13:15:59 +0200
commit4a2209eed678fd4060de0c2d47758cb8d21779dc (patch)
treed9ddc892004f15eddcc9d0146b845c31f54c6ddd
downloadgentoo-personal-overlay-4a2209eed678fd4060de0c2d47758cb8d21779dc.tar.gz
gentoo-personal-overlay-4a2209eed678fd4060de0c2d47758cb8d21779dc.tar.bz2
gentoo-personal-overlay-4a2209eed678fd4060de0c2d47758cb8d21779dc.zip
Initial personal gentoo overlay
-rw-r--r--media-sound/pulsemixer/Manifest1
-rw-r--r--media-sound/pulsemixer/pulsemixer-1.1.0.ebuild22
-rw-r--r--metadata/layout.conf4
-rw-r--r--net-dialup/sterm/files/Fix-install-strip.patch36
-rw-r--r--net-dialup/sterm/sterm-20170112.ebuild24
-rw-r--r--profiles/base/eapi1
-rw-r--r--profiles/base/package.mask8
-rw-r--r--profiles/base/package.use13
-rw-r--r--profiles/base/package.use.mask2
-rw-r--r--profiles/base/packages56
-rw-r--r--profiles/cynerd-laptop/eapi1
-rw-r--r--profiles/cynerd-laptop/package.use2
-rw-r--r--profiles/cynerd-laptop/packages2
-rw-r--r--profiles/cynerd-laptop/parent5
-rw-r--r--profiles/desktop/eapi1
-rw-r--r--profiles/desktop/package.accept_keywords14
-rw-r--r--profiles/desktop/package.mask3
-rw-r--r--profiles/desktop/package.use26
-rw-r--r--profiles/desktop/package.use.mask5
-rw-r--r--profiles/desktop/packages107
-rw-r--r--profiles/desktop/parent1
-rw-r--r--profiles/laptop/eapi1
-rw-r--r--profiles/laptop/package.accept_keywords4
-rw-r--r--profiles/laptop/packages14
-rw-r--r--profiles/laptop/parent1
-rw-r--r--profiles/latex/eapi1
-rw-r--r--profiles/latex/package.accept_keywords3
-rw-r--r--profiles/latex/package.use4
-rw-r--r--profiles/latex/packages1
-rw-r--r--profiles/profiles.desc1
-rw-r--r--profiles/qemu/eapi1
-rw-r--r--profiles/qemu/package.use1
-rw-r--r--profiles/qemu/package.use.mask2
-rw-r--r--profiles/qemu/packages3
-rw-r--r--profiles/repo_name1
-rw-r--r--profiles/steam/eapi1
-rw-r--r--profiles/steam/packages36
37 files changed, 409 insertions, 0 deletions
diff --git a/media-sound/pulsemixer/Manifest b/media-sound/pulsemixer/Manifest
new file mode 100644
index 0000000..1abf1aa
--- /dev/null
+++ b/media-sound/pulsemixer/Manifest
@@ -0,0 +1 @@
+DIST pulsemixer-1.1.0.tar.gz 11367 SHA256 7bc9b34c23771eaf947e1be21e805304d65b1e70e8c93ec0db237bb7f0f707ee SHA512 f48eef37aff5bd504be6f57a73f2c57dff68cfce313210c21189ea65b88284826c313aaa5fa84c5a7b98f55368e23d426f30f5efb717c1821934903cd9c85f06 WHIRLPOOL 37f885aee152c5d070a9eb14dc6aef526055d182ca6dcb1121ef5a51789c2f9e6bef1546e2c58a3593f2605edbfa2f4096e522570217b2c8b9c8dac90a98f2a3
diff --git a/media-sound/pulsemixer/pulsemixer-1.1.0.ebuild b/media-sound/pulsemixer/pulsemixer-1.1.0.ebuild
new file mode 100644
index 0000000..4495e27
--- /dev/null
+++ b/media-sound/pulsemixer/pulsemixer-1.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Ncurses mixer for pulseaudio"
+HOMEPAGE="https://github.com/GeorgeFilipkin/pulsemixer"
+SRC_URI="https://github.com/GeorgeFilipkin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/python-3
+ media-sound/pulseaudio"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin pulsemixer
+ dodoc README.md
+}
diff --git a/metadata/layout.conf b/metadata/layout.conf
new file mode 100644
index 0000000..0a99456
--- /dev/null
+++ b/metadata/layout.conf
@@ -0,0 +1,4 @@
+masters = gentoo
+auto-sync = false
+profile-formats = profile-set
+thin-manifests = true
diff --git a/net-dialup/sterm/files/Fix-install-strip.patch b/net-dialup/sterm/files/Fix-install-strip.patch
new file mode 100644
index 0000000..ed7da33
--- /dev/null
+++ b/net-dialup/sterm/files/Fix-install-strip.patch
@@ -0,0 +1,36 @@
+From da180154a36f14169ed80da310e378ae38516ba8 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <karel.koci@nic.cz>
+Date: Mon, 5 Dec 2016 07:41:40 +0100
+Subject: [PATCH 1/2] Fix install strip
+
+Strip can be used only on executables, adding it to all install
+commands causes error on some systems.
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 2cc363c..539342a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -2,7 +2,7 @@ CFLAGS = -O2 -Wall -g
+ LDLIBS = -llockdev
+
+ PREFIX ?= /usr/local
+-INSTALL ?= install -s
++INSTALL ?= install
+
+ all: sterm
+
+@@ -11,7 +11,7 @@ clean:
+
+ install: all
+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/bin
+- $(INSTALL) -m 755 sterm $(DESTDIR)$(PREFIX)/bin
++ $(INSTALL) -s -m 755 sterm $(DESTDIR)$(PREFIX)/bin
+ ifneq ($(NO_MAN),1)
+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/share/man/man1
+ $(INSTALL) -m 644 sterm.man $(DESTDIR)$(PREFIX)/share/man/man1/sterm.1
+--
+2.10.2
+
diff --git a/net-dialup/sterm/sterm-20170112.ebuild b/net-dialup/sterm/sterm-20170112.ebuild
new file mode 100644
index 0000000..d3ab7b9
--- /dev/null
+++ b/net-dialup/sterm/sterm-20170112.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils git-r3
+
+DESCRIPTION="Simple serial terminal"
+HOMEPAGE="https://rtime.felk.cvut.cz/gitweb/sojka/sterm.git"
+
+EGIT_REPO_URI="git://rtime.felk.cvut.cz/sojka/sterm.git"
+EGIT_COMMIT="${PV}"
+
+LICENSE="GPL-3.0+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/lockdev"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/Fix-install-strip.patch"
+}
diff --git a/profiles/base/eapi b/profiles/base/eapi
new file mode 100644
index 0000000..1e8b314
--- /dev/null
+++ b/profiles/base/eapi
@@ -0,0 +1 @@
+6
diff --git a/profiles/base/package.mask b/profiles/base/package.mask
new file mode 100644
index 0000000..b11e930
--- /dev/null
+++ b/profiles/base/package.mask
@@ -0,0 +1,8 @@
+# Oh yes I don't need nano
+app-editors/nano
+
+# Something from stage
+<sys-devel/libtool-2.4.3-r2
+<sys-apps/openrc-0.13.0
+<sys-process/procps-3.3.9-r2
+<dev-lang/perl-5.18.0
diff --git a/profiles/base/package.use b/profiles/base/package.use
new file mode 100644
index 0000000..be1f85a
--- /dev/null
+++ b/profiles/base/package.use
@@ -0,0 +1,13 @@
+# Busybox (static for initramfs)
+sys-apps/busybox static
+
+# Vim
+app-editors/vim perl python vim-pager cscope
+# Python
+dev-lang/python:2.7 sqlite
+# PNG
+media-libs/libpng apng
+
+# Various
+app-text/xmlto text
+dev-libs/libxml2 python
diff --git a/profiles/base/package.use.mask b/profiles/base/package.use.mask
new file mode 100644
index 0000000..1c7bf89
--- /dev/null
+++ b/profiles/base/package.use.mask
@@ -0,0 +1,2 @@
+# IP utils
+net-misc/iputils caps filecaps
diff --git a/profiles/base/packages b/profiles/base/packages
new file mode 100644
index 0000000..744f208
--- /dev/null
+++ b/profiles/base/packages
@@ -0,0 +1,56 @@
+# admin
+app-admin/sudo
+sys-process/lsof
+sys-process/cronie
+app-admin/syslog-ng
+sys-apps/mlocate
+sys-apps/lshw
+net-vpn/openvpn
+dev-util/strace
+dev-vcs/tig
+app-portage/mirrorselect
+app-portage/pfl
+app-portage/cpuid2cpuflags
+
+# vim
+app-editors/vim
+app-vim/vim-spell-cs
+app-vim/vim-spell-en
+
+# Other cli programs
+sys-process/htop
+sys-fs/ncdu
+app-text/sdcv
+
+# Shells
+app-shells/zsh
+app-shells/zsh-completions
+app-shells/gentoo-zsh-completions
+app-shells/bash-completion
+
+# Network
+net-misc/dhcpcd
+net-misc/ntp
+net-dns/bind-tools
+net-analyzer/nmap
+net-misc/dhcp
+
+# Drives and FS
+sys-apps/hdparm
+sys-apps/smartmontools
+sys-block/parted
+sys-fs/btrfs-progs
+sys-fs/exfat-utils
+sys-fs/dosfstools
+
+# Color highlight of less
+dev-util/source-highlight
+
+# Linux
+sys-kernel/linux-firmware
+sys-kernel/gentoo-sources
+sys-apps/usbutils
+sys-boot/efibootmgr
+sys-boot/syslinux
+sys-fs/btrfs-progs
+sys-fs/cryptsetup
diff --git a/profiles/cynerd-laptop/eapi b/profiles/cynerd-laptop/eapi
new file mode 100644
index 0000000..1e8b314
--- /dev/null
+++ b/profiles/cynerd-laptop/eapi
@@ -0,0 +1 @@
+6
diff --git a/profiles/cynerd-laptop/package.use b/profiles/cynerd-laptop/package.use
new file mode 100644
index 0000000..49fb627
--- /dev/null
+++ b/profiles/cynerd-laptop/package.use
@@ -0,0 +1,2 @@
+# Required by chromium
+dev-libs/libxml2 icu
diff --git a/profiles/cynerd-laptop/packages b/profiles/cynerd-laptop/packages
new file mode 100644
index 0000000..381b3d6
--- /dev/null
+++ b/profiles/cynerd-laptop/packages
@@ -0,0 +1,2 @@
+# For now let's use chrome
+www-client/google-chrome
diff --git a/profiles/cynerd-laptop/parent b/profiles/cynerd-laptop/parent
new file mode 100644
index 0000000..4c2160f
--- /dev/null
+++ b/profiles/cynerd-laptop/parent
@@ -0,0 +1,5 @@
+../laptop
+../qemu
+../latex
+../steam
+/usr/portage/profiles/default/linux/amd64/13.0
diff --git a/profiles/desktop/eapi b/profiles/desktop/eapi
new file mode 100644
index 0000000..1e8b314
--- /dev/null
+++ b/profiles/desktop/eapi
@@ -0,0 +1 @@
+6
diff --git a/profiles/desktop/package.accept_keywords b/profiles/desktop/package.accept_keywords
new file mode 100644
index 0000000..68965d4
--- /dev/null
+++ b/profiles/desktop/package.accept_keywords
@@ -0,0 +1,14 @@
+# i3
+media-sound/playerctl ~amd64
+
+# pidgin plugins
+x11-plugins/purple-facebook ~amd64
+x11-plugins/purple-hangouts ~amd64
+
+# neomutt
+mail-client/neomutt ~amd64
+
+# Web browsers
+www-client/conkeror ~amd64
+# For firefox
+dev-libs/nss ~amd64
diff --git a/profiles/desktop/package.mask b/profiles/desktop/package.mask
new file mode 100644
index 0000000..3defb77
--- /dev/null
+++ b/profiles/desktop/package.mask
@@ -0,0 +1,3 @@
+# I don't want to use consolekit and polkit. I am using my coputer on my own. I don't need this.
+sys-auth/consolekit
+sys-auth/polkit
diff --git a/profiles/desktop/package.use b/profiles/desktop/package.use
new file mode 100644
index 0000000..9d977ee
--- /dev/null
+++ b/profiles/desktop/package.use
@@ -0,0 +1,26 @@
+# Pulseaudio (systemwide)
+media-sound/pulseaudio alsa alsa-plugin bluetooth system-wide
+
+# Neomutt
+mail-client/neomutt sidebar gpg doc
+# urxvt
+x11-terms/rxvt-unicode 256-color font-styles mousewheel perl secondary-wheel unicode3 xft
+
+# MPD
+media-sound/mpd eventfd signalfd glib id3tag libmpdclient mpg123 network nfs pipe recorder
+media-sound/ncmpcpp clock outputs visualizer
+# ncmpcpp
+>=dev-libs/boost-1.62.0-r1 icu
+
+# Inkscape
+app-text/poppler cairo
+# vlc
+sys-libs/zlib minizip
+# llpp
+dev-ml/lablgl glut
+# pidgin
+media-libs/gd jpeg png
+
+# Qt
+dev-qt/qtgui gtkstyle
+dev-libs/libpcre pcre16
diff --git a/profiles/desktop/package.use.mask b/profiles/desktop/package.use.mask
new file mode 100644
index 0000000..d0c2e7e
--- /dev/null
+++ b/profiles/desktop/package.use.mask
@@ -0,0 +1,5 @@
+# Pulseaudio (systemwide)
+media-sound/pulseaudio X
+
+# urxvt
+x11-terms/rxvt-unicode vanilla
diff --git a/profiles/desktop/packages b/profiles/desktop/packages
new file mode 100644
index 0000000..0005775
--- /dev/null
+++ b/profiles/desktop/packages
@@ -0,0 +1,107 @@
+# Various
+net-dialup/sterm
+gnome-extra/gucharmap
+app-text/llpp
+app-admin/pass
+
+# i3
+x11-wm/i3
+x11-misc/i3blocks
+x11-misc/i3lock
+x11-misc/dmenu
+x11-misc/dunst
+
+# urxvt
+x11-terms/rxvt-unicode
+x11-misc/urxvt-font-size
+x11-misc/urxvt-perls
+
+# X11
+x11-base/xorg-x11
+x11-drivers/xf86-input-evdev
+x11-apps/mesa-progs
+
+x11-base/xorg-drivers
+x11-base/xorg-server
+x11-apps/setxkbmap
+x11-apps/xev
+x11-apps/xinit
+x11-apps/xprop
+x11-apps/xrandr
+x11-libs/cairo
+x11-misc/xdotool
+
+# Mail
+mail-client/neomutt
+mail-mta/msmtp
+app-misc/abook
+net-misc/urlview
+www-client/lynx
+net-mail/offlineimap
+dev-python/python-daemon
+
+# Web
+www-client/conkeror
+
+# Media
+media-sound/pulseaudio
+media-sound/mpc
+media-sound/mpd
+media-sound/ncmpcpp
+media-sound/pulsemixer
+media-video/vlc
+media-gfx/feh
+
+# Pidgin
+net-im/pidgin
+x11-plugins/pidgin-encryption
+x11-plugins/pidgin-gpg
+x11-plugins/pidgin-hotkeys
+x11-plugins/pidgin-latex
+x11-plugins/pidgin-libnotify
+x11-plugins/pidgin-window_merge
+x11-plugins/purple-facebook
+x11-plugins/purple-hangouts
+
+# Creations
+media-sound/audacity
+media-gfx/gimp
+media-gfx/inkscape
+
+# Themes
+x11-themes/clearlooks-phenix
+x11-themes/gnome-icon-theme
+x11-themes/gnome-icon-theme-extras
+x11-themes/gnome-icon-theme-symbolic
+# Use gtk+ theme in Qt applications
+dev-qt/qtgui
+# Fonts
+virtual/ttf-fonts
+dev-texlive/texlive-fontsextra
+media-fonts/arkpandora
+media-fonts/arphicfonts
+media-fonts/artwiz-aleczapka-en
+media-fonts/bitstream-cyberbit
+media-fonts/corefonts
+media-fonts/dejavu
+media-fonts/droid
+media-fonts/freefont
+media-fonts/freefonts
+media-fonts/hack
+media-fonts/ipamonafont
+media-fonts/ja-ipafonts
+media-fonts/liberation-fonts
+media-fonts/libertine
+media-fonts/mathematica-fonts
+media-fonts/noto
+media-fonts/quivira
+media-fonts/sil-gentium
+media-fonts/symbola
+media-fonts/takao-fonts
+media-fonts/terminus-font
+media-fonts/ttf-bitstream-vera
+media-fonts/ubuntu-font-family
+media-fonts/unifont
+media-fonts/urw-fonts
+media-fonts/wqy-microhei
+media-fonts/wqy-zenhei
diff --git a/profiles/desktop/parent b/profiles/desktop/parent
new file mode 100644
index 0000000..eb001c6
--- /dev/null
+++ b/profiles/desktop/parent
@@ -0,0 +1 @@
+../base
diff --git a/profiles/laptop/eapi b/profiles/laptop/eapi
new file mode 100644
index 0000000..1e8b314
--- /dev/null
+++ b/profiles/laptop/eapi
@@ -0,0 +1 @@
+6
diff --git a/profiles/laptop/package.accept_keywords b/profiles/laptop/package.accept_keywords
new file mode 100644
index 0000000..1f346e1
--- /dev/null
+++ b/profiles/laptop/package.accept_keywords
@@ -0,0 +1,4 @@
+# powertop
+sys-power/powertop ~amd64
+# Syslinux
+sys-boot/syslinux ~amd64
diff --git a/profiles/laptop/packages b/profiles/laptop/packages
new file mode 100644
index 0000000..4bae3f4
--- /dev/null
+++ b/profiles/laptop/packages
@@ -0,0 +1,14 @@
+# Power
+sys-apps/hdparm
+sys-power/acpid
+sys-power/pm-utils
+sys-power/powertop
+
+# Wifi
+net-wireless/iw
+net-wireless/rfkill
+net-wireless/wireless-tools
+net-wireless/wpa_supplicant
+
+# i2c
+sys-apps/i2c-tools
diff --git a/profiles/laptop/parent b/profiles/laptop/parent
new file mode 100644
index 0000000..5b26f1c
--- /dev/null
+++ b/profiles/laptop/parent
@@ -0,0 +1 @@
+../desktop
diff --git a/profiles/latex/eapi b/profiles/latex/eapi
new file mode 100644
index 0000000..1e8b314
--- /dev/null
+++ b/profiles/latex/eapi
@@ -0,0 +1 @@
+6
diff --git a/profiles/latex/package.accept_keywords b/profiles/latex/package.accept_keywords
new file mode 100644
index 0000000..dd94e4d
--- /dev/null
+++ b/profiles/latex/package.accept_keywords
@@ -0,0 +1,3 @@
+# Latex (texlive)
+#app-text/texlive ~amd64
+media-libs/harfbuzz ~amd64
diff --git a/profiles/latex/package.use b/profiles/latex/package.use
new file mode 100644
index 0000000..c74d0cc
--- /dev/null
+++ b/profiles/latex/package.use
@@ -0,0 +1,4 @@
+app-text/texlive epspdf extra graphics metapost pdfannotextractor pstricks science xindy
+media-libs/harfbuzz icu
+app-text/texlive-core xetex
+media-libs/gd fontconfig
diff --git a/profiles/latex/packages b/profiles/latex/packages
new file mode 100644
index 0000000..3220e27
--- /dev/null
+++ b/profiles/latex/packages
@@ -0,0 +1 @@
+app-text/texlive
diff --git a/profiles/profiles.desc b/profiles/profiles.desc
new file mode 100644
index 0000000..4265d92
--- /dev/null
+++ b/profiles/profiles.desc
@@ -0,0 +1 @@
+amd64 cynerd-laptop stable
diff --git a/profiles/qemu/eapi b/profiles/qemu/eapi
new file mode 100644
index 0000000..1e8b314
--- /dev/null
+++ b/profiles/qemu/eapi
@@ -0,0 +1 @@
+6
diff --git a/profiles/qemu/package.use b/profiles/qemu/package.use
new file mode 100644
index 0000000..ed48adc
--- /dev/null
+++ b/profiles/qemu/package.use
@@ -0,0 +1 @@
+app-emulation/qemu usb vhost-net virgl vte xattr fdt aio spice
diff --git a/profiles/qemu/package.use.mask b/profiles/qemu/package.use.mask
new file mode 100644
index 0000000..9edb939
--- /dev/null
+++ b/profiles/qemu/package.use.mask
@@ -0,0 +1,2 @@
+# We can have only gstreamer or pulseaudio so mask one of those
+net-misc/spice-gtk gstreamer
diff --git a/profiles/qemu/packages b/profiles/qemu/packages
new file mode 100644
index 0000000..f93ae0d
--- /dev/null
+++ b/profiles/qemu/packages
@@ -0,0 +1,3 @@
+# Just some virtualisation related packages
+app-emulation/qemu
+net-misc/spice-gtk
diff --git a/profiles/repo_name b/profiles/repo_name
new file mode 100644
index 0000000..8d36c64
--- /dev/null
+++ b/profiles/repo_name
@@ -0,0 +1 @@
+personal
diff --git a/profiles/steam/eapi b/profiles/steam/eapi
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/profiles/steam/eapi
@@ -0,0 +1 @@
+5
diff --git a/profiles/steam/packages b/profiles/steam/packages
new file mode 100644
index 0000000..1aad88a
--- /dev/null
+++ b/profiles/steam/packages
@@ -0,0 +1,36 @@
+dev-libs/glib:2
+dev-libs/libgcrypt
+dev-libs/nspr
+dev-libs/nss
+gnome-base/gconf
+media-libs/alsa-lib
+media-libs/fontconfig
+media-libs/freetype:2
+media-libs/libjpeg-turbo
+media-libs/libogg
+media-libs/libpng:1.2
+media-libs/libsdl
+media-libs/libtheora
+media-libs/libvorbis
+media-libs/libtxc_dxtn
+media-libs/openal
+net-misc/curl
+net-print/cups
+sys-apps/dbus
+>=sys-devel/gcc-4.6.0
+>=sys-libs/glibc-2.15
+>=sys-libs/zlib-1.2.4
+virtual/libusb:1
+virtual/opengl
+x11-libs/cairo
+x11-libs/gdk-pixbuf
+x11-libs/gtk+:2
+x11-libs/libX11
+x11-libs/libXext
+x11-libs/libXfixes
+x11-libs/libXi
+x11-libs/libXrandr
+x11-libs/libXrender
+x11-libs/libXScrnSaver
+x11-libs/pango
+x11-libs/pixman