From 6746e43050c1fce7a44e64e6e9cca583b8308521 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
Date: Sun, 31 May 2020 11:35:11 +0200
Subject: updater-ng: add new patch for lua

---
 ...c-fix-check-for-busybox-when-cross-compil.patch | 31 ++++++++++++++++++++++
 ...c-check-for-plain-Lua-first-instead-of-lu.patch | 29 ++++++++++++++++++++
 ...c-fix-check-for-busybox-when-cross-compil.patch | 31 ----------------------
 3 files changed, 60 insertions(+), 31 deletions(-)
 create mode 100644 updater-ng/patches/0001-configure.ac-fix-check-for-busybox-when-cross-compil.patch
 create mode 100644 updater-ng/patches/0002-configure.ac-check-for-plain-Lua-first-instead-of-lu.patch
 delete mode 100644 updater-ng/patches/configure.ac-fix-check-for-busybox-when-cross-compil.patch

(limited to 'updater-ng')

diff --git a/updater-ng/patches/0001-configure.ac-fix-check-for-busybox-when-cross-compil.patch b/updater-ng/patches/0001-configure.ac-fix-check-for-busybox-when-cross-compil.patch
new file mode 100644
index 0000000..e54b550
--- /dev/null
+++ b/updater-ng/patches/0001-configure.ac-fix-check-for-busybox-when-cross-compil.patch
@@ -0,0 +1,31 @@
+From 1048eccde0342f5aa3133623f9cafbfa92eaf039 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
+Date: Thu, 21 May 2020 21:13:37 +0200
+Subject: [PATCH 1/2] configure.ac: fix check for busybox when cross compiling
+
+AC_CHECK_FILE works only if cross compilation is not performed. The
+reason is that it tries to check for existence of file on native system.
+
+We want check if argument is file so implement check doing exactly that
+with plain test.
+---
+ configure.ac | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index e384eae3..aec813cb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -18,7 +18,8 @@ AM_CONDITIONAL([BUSYBOX_EMBED], [test -n "$with_embed_busybox"])
+ AC_SUBST([BUSYBOX_EMBED], [$with_embed_busybox])
+ AS_IF([test -n "$with_embed_busybox"],
+   [
+-   AC_CHECK_FILE([$with_embed_busybox],,[AC_MSG_ERROR([Invalid argument for --with-embed-busybox])])
++   AS_IF([test -f "$with_embed_busybox"],,
++	 [AC_MSG_ERROR([Invalid argument for --with-embed-busybox])])
+    AC_DEFINE_UNQUOTED([BUSYBOX_EMBED], [$with_embed_busybox], [Embded Busybox])
+   ])
+ 
+-- 
+2.26.2
+
diff --git a/updater-ng/patches/0002-configure.ac-check-for-plain-Lua-first-instead-of-lu.patch b/updater-ng/patches/0002-configure.ac-check-for-plain-Lua-first-instead-of-lu.patch
new file mode 100644
index 0000000..2bf1f47
--- /dev/null
+++ b/updater-ng/patches/0002-configure.ac-check-for-plain-Lua-first-instead-of-lu.patch
@@ -0,0 +1,29 @@
+From 2fd732bc6ed35761142c96122912febc41b021d2 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
+Date: Sun, 31 May 2020 11:31:46 +0200
+Subject: [PATCH 2/2] configure.ac: check for plain Lua first instead of lua5.1
+
+Checking for lua with version 5.1 is required for systems with single
+version of Lua while lua5.1 is required for those providing multiple
+versions.
+---
+ configure.ac | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index aec813cb..2cc89aeb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -23,7 +23,8 @@ AS_IF([test -n "$with_embed_busybox"],
+    AC_DEFINE_UNQUOTED([BUSYBOX_EMBED], [$with_embed_busybox], [Embded Busybox])
+   ])
+ 
+-PKG_CHECK_MODULES([LUA], [lua5.1])
++PKG_CHECK_MODULES([LUA], [lua = 5.1],,
++  [PKG_CHECK_MODULES([LUA], [lua5.1])])
+ PKG_CHECK_MODULES([LIBEVENT], [libevent >= 2.0])
+ PKG_CHECK_MODULES([LIBARCHIVE], [libarchive])
+ PKG_CHECK_MODULES([LIBCURL], [libcurl])
+-- 
+2.26.2
+
diff --git a/updater-ng/patches/configure.ac-fix-check-for-busybox-when-cross-compil.patch b/updater-ng/patches/configure.ac-fix-check-for-busybox-when-cross-compil.patch
deleted file mode 100644
index 0424f0e..0000000
--- a/updater-ng/patches/configure.ac-fix-check-for-busybox-when-cross-compil.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 1048eccde0342f5aa3133623f9cafbfa92eaf039 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
-Date: Thu, 21 May 2020 21:13:37 +0200
-Subject: [PATCH] configure.ac: fix check for busybox when cross compiling
-
-AC_CHECK_FILE works only if cross compilation is not performed. The
-reason is that it tries to check for existence of file on native system.
-
-We want check if argument is file so implement check doing exactly that
-with plain test.
----
- configure.ac | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index e384eae3..aec813cb 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -18,7 +18,8 @@ AM_CONDITIONAL([BUSYBOX_EMBED], [test -n "$with_embed_busybox"])
- AC_SUBST([BUSYBOX_EMBED], [$with_embed_busybox])
- AS_IF([test -n "$with_embed_busybox"],
-   [
--   AC_CHECK_FILE([$with_embed_busybox],,[AC_MSG_ERROR([Invalid argument for --with-embed-busybox])])
-+   AS_IF([test -f "$with_embed_busybox"],,
-+	 [AC_MSG_ERROR([Invalid argument for --with-embed-busybox])])
-    AC_DEFINE_UNQUOTED([BUSYBOX_EMBED], [$with_embed_busybox], [Embded Busybox])
-   ])
- 
--- 
-2.26.2
-
-- 
cgit v1.2.3