From 4e2388f8435acd012cc480686c80f70d3358d513 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
Date: Fri, 11 Mar 2022 12:47:01 +0100
Subject: bigclown-firmware-tool: update to newer version

---
 python-ftdi/Makefile | 42 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
 create mode 100644 python-ftdi/Makefile

(limited to 'python-ftdi')

diff --git a/python-ftdi/Makefile b/python-ftdi/Makefile
new file mode 100644
index 0000000..25cd38e
--- /dev/null
+++ b/python-ftdi/Makefile
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2022 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-pyftdi
+PKG_VERSION:=0.53.3
+PKG_RELEASE:=1
+
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+PYPI_NAME:=pyftdi
+PKG_HASH:=4ef20c246bdb0f278d283337d7a6e69cf9bdb0ead525e7ad867d9e46ad26e613
+
+include $(TOPDIR)/feeds/packages/lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+define Package/python3-pyftdi
+  SECTION:=lang-python
+  CATEGORY:=Languages
+  SUBMENU:=Python
+  TITLE:=FTDI device driver
+  URL:=http://github.com/eblot/pyftdi
+  DEPENDS:=+python3-light \
+    +python3-pyusb \
+    +python3-pyserial
+  VARIANT:=python3
+endef
+
+define Package/python3-pyftdi/description
+  FTDI device driver (pure Python)
+endef
+
+$(eval $(call Py3Package,python3-pyftdi))
+$(eval $(call BuildPackage,python3-pyftdi))
+$(eval $(call BuildPackage,python3-pyftdi-src))
-- 
cgit v1.2.3