From f92e15fbe52427e51260f60fe902da18ae85fd2a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
Date: Thu, 13 Sep 2018 00:17:08 +0200
Subject: bigclown-gateway: ok no device link

It seems to not work so just drop it.
---
 bigclown-gateway/Makefile      |  4 +---
 bigclown-gateway/files/config  |  2 +-
 bigclown-gateway/files/hotplug | 32 --------------------------------
 bigclown-gateway/files/init    |  2 +-
 4 files changed, 3 insertions(+), 37 deletions(-)
 delete mode 100644 bigclown-gateway/files/hotplug

diff --git a/bigclown-gateway/Makefile b/bigclown-gateway/Makefile
index 17bcbae..df17fd6 100644
--- a/bigclown-gateway/Makefile
+++ b/bigclown-gateway/Makefile
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bigclown-gateway
-PKG_RELEASE:=5
+PKG_RELEASE:=1
 PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-gateway.git
 PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
 
@@ -21,8 +21,6 @@ define Py3Package/$(PKG_NAME)/install
 	$(INSTALL_CONF) ./files/config $(1)/etc/config/bigclown-gateway
 	$(INSTALL_DIR) $(1)/etc/init.d
 	$(INSTALL_BIN) ./files/init $(1)/etc/init.d/bigclown-gateway
-	$(INSTALL_DIR) $(1)/etc/hotplug.d/usb
-	$(INSTALL_DATA) ./files/hotplug $(1)/etc/hotplug.d/usb/50-bigclown-usb-dongle
 endef
 
 define Package/$(PKG_NAME)/conffiles
diff --git a/bigclown-gateway/files/config b/bigclown-gateway/files/config
index d880476..7fa3977 100644
--- a/bigclown-gateway/files/config
+++ b/bigclown-gateway/files/config
@@ -1,7 +1,7 @@
 
 config config 'gateway'
 	option name 'usb-dongle'
-	option device '/dev/bcUD0'
+	option device '/dev/ttyUSB0'
 	option automatic_rename_kit_nodes '1'
 
 config config 'mqtt'
diff --git a/bigclown-gateway/files/hotplug b/bigclown-gateway/files/hotplug
deleted file mode 100644
index fb1ef59..0000000
--- a/bigclown-gateway/files/hotplug
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/bin/sh
-DEVNAME="$(ls "/sys/$DEVPATH" | grep "^ttyUSB[0-9]*$")"
-[ -n "$DEVNAME" ] || exit 0
-[ "$ID_VENDOR" = "0403" ] || exit 0
-[ "$ID_MODEL" = "6015" ] || exit 0
-echo "$ID_SERIAL" | grep -q ".*bc-usb-dongle.*" || exit 0
-
-action_add() {
-	local id=0
-	while [ -e "/dev/bcUD$id" ]; do
-		id=$(expr $id + 1)
-	done
-	ln -sf "/dev/$DEVNAME" "/dev/bcUD$id"
-}
-
-action_remove() {
-	local id=0
-	while [ "$(readlink "/dev/bcUD$id")" = "$DEVNAME" ]; do
-		[ -e "/dev/bcUD$id" ] || return 0
-		id=$(expr $id + 1)
-	done
-	rm "/dev/bcUD$id"
-}
-
-case "$ACTION" in
-	add)
-		action_add
-		;;
-	remove)
-		action_remove
-		;;
-esac
diff --git a/bigclown-gateway/files/init b/bigclown-gateway/files/init
index 28f6e7e..090cc06 100755
--- a/bigclown-gateway/files/init
+++ b/bigclown-gateway/files/init
@@ -27,7 +27,7 @@ start_service() {
 
 	append gateway name 'name:' usb-dongle
 	# TODO add udev rules and use different default here
-	append gateway device 'device:' /dev/bcUD0
+	append gateway device 'device:' /dev/ttyUSB0
 	append gateway automatic_rename_kit_nodes 'automatic_rename_kit_nodes:' 1
 	append gateway base_topic_prefix 'base_topic_prefix:'
 
-- 
cgit v1.2.3