summaryrefslogtreecommitdiff
path: root/updater-ng
diff options
context:
space:
mode:
Diffstat (limited to 'updater-ng')
-rw-r--r--updater-ng/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/updater-ng/Makefile b/updater-ng/Makefile
index 257ed8c..56967b6 100644
--- a/updater-ng/Makefile
+++ b/updater-ng/Makefile
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=updater-ng
PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater.git
-PKG_SOURCE_BRANCH:=master
+PKG_SOURCE_BRANCH:=opkg-wrapper-ignore
PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
HOST_BUILD_DEPENDS:=curl/host libevent2/host lua/host
PKG_BUILD_DEPENDS:=busybox
-include $(TOPDIR)/package/autopkg-branch.mk
+include $(TOPDIR)/feeds/personal/autopkg-branch.mk
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
$(call include_mk, python3-package.mk)
@@ -166,6 +166,8 @@ define Package/$(PKG_NAME)-opkg/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/localrepo/content2localrepo $(1)/usr/share/updater/opkg-content2localrepo.sh
$(INSTALL_DIR) $(1)/etc/updater/conf.d
$(INSTALL_CONF) $(PKG_BUILD_DIR)/src/opkg-wrapper/opkg.lua $(1)/etc/updater/conf.d/opkg.lua
+ $(INSTALL_DIR) $(1)/etc/updater/opkg-ignore
+ touch $(1)/etc/updater/opkg-ignore/.keep
endef
# We are calling migration to localrepo from updater-ng-opkg package posinst as