summaryrefslogtreecommitdiff
path: root/updater-ng/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'updater-ng/Makefile')
-rw-r--r--updater-ng/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/updater-ng/Makefile b/updater-ng/Makefile
index b8dfb83..95af6eb 100644
--- a/updater-ng/Makefile
+++ b/updater-ng/Makefile
@@ -12,16 +12,28 @@ PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater/updater.git
PKG_SOURCE_BRANCH:=uri
PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
-HOST_BUILD_DEPENDS:=curl/host libevent2/host lua/host
-PKG_BUILD_DEPENDS:=busybox
+HOST_BUILD_DEPENDS:= \
+ curl/host \
+ libevent2/host \
+ lua/host \
+ uriparser/host \
+ uthash/host
+PKG_BUILD_DEPENDS:=busybox uthash
include $(INCLUDE_DIR)/autopkg-branch.mk
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
define Package/$(PKG_NAME)
- TITLE:=The next generation updater
- DEPENDS:=+liblua +libuci-lua +libevent2 +usign +libcurl +ca-certificates
+ TITLE:=The next generation updater
+ DEPENDS:=\
+ +liblua \
+ +libuci-lua \
+ +libevent2 \
+ +libcurl \
+ +liburiparser \
+ +usign \
+ +ca-certificates
endef
define Package/$(PKG_NAME)/install