summaryrefslogtreecommitdiff
path: root/updater-ng/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'updater-ng/Makefile')
-rw-r--r--updater-ng/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/updater-ng/Makefile b/updater-ng/Makefile
index 257ed8c..d243904 100644
--- a/updater-ng/Makefile
+++ b/updater-ng/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=updater-ng
PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater.git
-PKG_SOURCE_BRANCH:=master
+PKG_SOURCE_BRANCH:=opkg-wrapper-ignore
PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
HOST_BUILD_DEPENDS:=curl/host libevent2/host lua/host
PKG_BUILD_DEPENDS:=busybox
@@ -166,6 +166,8 @@ define Package/$(PKG_NAME)-opkg/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/localrepo/content2localrepo $(1)/usr/share/updater/opkg-content2localrepo.sh
$(INSTALL_DIR) $(1)/etc/updater/conf.d
$(INSTALL_CONF) $(PKG_BUILD_DIR)/src/opkg-wrapper/opkg.lua $(1)/etc/updater/conf.d/opkg.lua
+ $(INSTALL_DIR) $(1)/etc/updater/opkg-ignore
+ touch $(1)/etc/updater/opkg-ignore/.keep
endef
# We are calling migration to localrepo from updater-ng-opkg package posinst as