summaryrefslogtreecommitdiff
path: root/syncthing/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'syncthing/Makefile')
-rw-r--r--syncthing/Makefile65
1 files changed, 0 insertions, 65 deletions
diff --git a/syncthing/Makefile b/syncthing/Makefile
deleted file mode 100644
index 52e148f..0000000
--- a/syncthing/Makefile
+++ /dev/null
@@ -1,65 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=syncthing
-PKG_VERSION:=1.18.1
-PKG_RELEASE:=$(AUTORELEASE)
-
-PKG_SOURCE:=syncthing-source-v$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/syncthing/syncthing/releases/download/v$(PKG_VERSION)
-PKG_HASH:=3f6b8e87a59e72ab3389d89364524e6abec454d4c36aaf3e334ac6fe37915584
-
-PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/$(PKG_NAME)
-
-PKG_MAINTAINER:=Paul Spooren <mail@aparcar.org>
-PKG_LICENSE:=MPL-2.0
-PKG_LICENSE_FILES:=LICENSE
-PKG_CPE_ID:=cpe:/a:syncthing:syncthing
-
-PKG_BUILD_DEPENDS:=golang/host
-PKG_BUILD_PARALLEL:=1
-PKG_USE_MIPS16:=0
-
-GO_PKG:=github.com/syncthing/syncthing/
-GO_PKG_BUILD_PKG:=github.com/syncthing/syncthing/cmd/syncthing/
-GO_PKG_INSTALL_EXTRA:=^gui/
-
-GO_PKG_LDFLAGS_X:=\
- github.com/syncthing/syncthing/lib/build.Version=v$(PKG_VERSION) \
- github.com/syncthing/syncthing/lib/build.Stamp=$(SOURCE_DATE_EPOCH) \
- github.com/syncthing/syncthing/lib/build.User=openwrt \
- github.com/syncthing/syncthing/lib/build.Host=openwrt \
- github.com/syncthing/syncthing/lib/build.Program=syncthing
-GO_PKG_TAGS:=noupgrade
-
-include $(INCLUDE_DIR)/package.mk
-include $(TOPDIR)/feeds/packages/lang/golang/golang-package.mk
-
-define Package/syncthing
- TITLE:=Continuous file synchronization program
- URL:=https://syncthing.net
- DEPENDS:=$(GO_ARCH_DEPENDS)
- SECTION:=utils
- CATEGORY:=Utilities
- USERID:=syncthing=499:syncthing=499
-endef
-
-define Package/syncthing/conffiles
-/etc/config/syncthing
-/etc/syncthing
-endef
-
-define Package/syncthing/description
- Syncthing replaces proprietary sync and cloud services with something
- open, trustworthy and decentralized. Your data is your data alone and
- you deserve to choose where it is stored, if it is shared with some
- third party and how it's transmitted over the Internet.
-endef
-
-define Package/syncthing/install
- $(call GoPackage/Package/Install/Bin,$(1))
-
- $(CP) ./files/* $(1)/
-endef
-
-$(eval $(call GoBinPackage,syncthing))
-$(eval $(call BuildPackage,syncthing))