summaryrefslogtreecommitdiff
path: root/shellrc
diff options
context:
space:
mode:
Diffstat (limited to 'shellrc')
-rw-r--r--shellrc/Makefile4
-rw-r--r--shellrc/files/profile.prompt.sh12
2 files changed, 15 insertions, 1 deletions
diff --git a/shellrc/Makefile b/shellrc/Makefile
index 5cf70a9..d13cd06 100644
--- a/shellrc/Makefile
+++ b/shellrc/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=shellrc
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=https://git.cynerd.cz/shellrc
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
@@ -33,6 +33,8 @@ Build/Compile:=:
define Package/$(PKG_NAME)/install
$(PKG_BUILD_DIR)/install --prefix "$(1)"
+ $(INSTALL_DIR) $(1)/etc/profile.d
+ $(INSTALL_DATA) ./files/profile.prompt.sh $(1)/etc/profile.d/prompt.sh
endef
define Package/$(PKG_NAME)-bash/install
diff --git a/shellrc/files/profile.prompt.sh b/shellrc/files/profile.prompt.sh
new file mode 100644
index 0000000..122a35b
--- /dev/null
+++ b/shellrc/files/profile.prompt.sh
@@ -0,0 +1,12 @@
+# Better prompt
+case "$TERM" in
+ xterm*|rxvt*)
+ export PS1='$(EC=$?
+[ $EC = 0 ] || echo -n "\e[1;33m($EC) "
+if [ `id -u` -eq "0" ]; then
+ echo -n "\[\e[1;31m\]\u@\h:\[\e[1;34m\]\W\[\e[1;31m\]\$\[\e[0m\] "
+else
+ echo -n "\[\e[1;32m\]\u@\h:\[\e[1;34m\]\W\[\e[1;32m\]\$\[\e[0m\] "
+fi)'
+ ;;
+esac