summaryrefslogtreecommitdiff
path: root/shellrc
diff options
context:
space:
mode:
Diffstat (limited to 'shellrc')
-rw-r--r--shellrc/Makefile58
1 files changed, 0 insertions, 58 deletions
diff --git a/shellrc/Makefile b/shellrc/Makefile
deleted file mode 100644
index 628dd9f..0000000
--- a/shellrc/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-#
-## Copyright (C) 2018 Karel Kočí
-#
-## This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-# #
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=shellrc
-PKG_RELEASE:=1
-PKG_SOURCE_URL:=https://git.cynerd.cz/shellrc
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-
-$(call include_mk, autopkg-tag.mk)
-include $(INCLUDE_DIR)/package.mk
-
-define Package/$(PKG_NAME)
- TITLE:=Shell initialization files
-endef
-
-define Package/$(PKG_NAME)-bash
- TITLE:=Shell initialization files bash specific
- DEPENDS:=$(PKG_NAME) bash
-endef
-
-define Package/$(PKG_NAME)-zsh
- TITLE:=Shell initialization files zsh specific
- DEPENDS:=$(PKG_NAME) zsh
-endef
-
-define Package/$(PKG_NAME)-ash
- TITLE:=Shell initialization files ash specific
- DEPENDS:=$(PKG_NAME)
-endef
-
-define Build/Compile
- true
-endef
-
-define Package/$(PKG_NAME)/install
- $(PKG_BUILD_DIR)/install --prefix "$(1)"
-endef
-
-define Package/$(PKG_NAME)-bash/install
- $(PKG_BUILD_DIR)/install --prefix "$(1)" --bash --no-base
-endef
-
-define Package/$(PKG_NAME)-zsh/install
- $(PKG_BUILD_DIR)/install --prefix "$(1)" --zsh --no-base
-endef
-
-define Package/$(PKG_NAME)-ash/install
- # TODO
- #$(PKG_BUILD_DIR)/install --prefix "$(1)" --ash --no-base
-endef
-
-$(eval $(call BuildPackage,$(PKG_NAME)))