summaryrefslogtreecommitdiff
path: root/shellrc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shellrc/Makefile')
-rw-r--r--shellrc/Makefile18
1 files changed, 2 insertions, 16 deletions
diff --git a/shellrc/Makefile b/shellrc/Makefile
index 1316349..5cf70a9 100644
--- a/shellrc/Makefile
+++ b/shellrc/Makefile
@@ -1,5 +1,5 @@
#
-## Copyright (C) 2018 Karel Kočí
+## Copyright (C) 2018-2019 Karel Kočí
#
## This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -29,14 +29,7 @@ define Package/$(PKG_NAME)-zsh
DEPENDS:=+$(PKG_NAME) +zsh
endef
-define Package/$(PKG_NAME)-ash
- TITLE:=Shell initialization files ash specific
- DEPENDS:=+$(PKG_NAME) +busybox
-endef
-
-define Build/Compile
- true
-endef
+Build/Compile:=:
define Package/$(PKG_NAME)/install
$(PKG_BUILD_DIR)/install --prefix "$(1)"
@@ -50,13 +43,6 @@ define Package/$(PKG_NAME)-zsh/install
$(PKG_BUILD_DIR)/install --prefix "$(1)" --zsh --no-base
endef
-define Package/$(PKG_NAME)-ash/install
- true
- # TODO
- #$(PKG_BUILD_DIR)/install --prefix "$(1)" --ash --no-base
-endef
-
$(eval $(call BuildPackage,$(PKG_NAME)))
$(eval $(call BuildPackage,$(PKG_NAME)-bash))
$(eval $(call BuildPackage,$(PKG_NAME)-zsh))
-$(eval $(call BuildPackage,$(PKG_NAME)-ash))