summaryrefslogtreecommitdiff
path: root/python3-six/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'python3-six/Makefile')
-rw-r--r--python3-six/Makefile38
1 files changed, 0 insertions, 38 deletions
diff --git a/python3-six/Makefile b/python3-six/Makefile
deleted file mode 100644
index 1aa2938..0000000
--- a/python3-six/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python3-six
-PKG_VERSION:=1.11.0
-PKG_RELEASE:=2
-
-PKG_SOURCE:=six-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://pypi.python.org/packages/source/s/six/
-PKG_MD5SUM:=d12789f9baf7e9fb2524c0c64f1773f8
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/six-$(PKG_VERSION)
-PKG_BUILD_DEPENDS:=python3-setuptools
-
-include $(INCLUDE_DIR)/package.mk
-$(call include_mk, python3-package.mk)
-
-define Package/python3-six
- SUBMENU:=Python
- SECTION:=lang
- CATEGORY:=Languages
- TITLE:=Python 2 and 3 compatibility utilities
- URL:=http://pypi.python.org/pypi/six/
- DEPENDS:=+python3
-endef
-
-define Package/python3-six/description
- Python 2 and 3 compatibility utilities
-endef
-
-define Build/Compile
- $(call Build/Compile/Py3Mod,, \
- install --root="$(PKG_INSTALL_DIR)" --prefix="/usr" \
- --single-version-externally-managed \
- )
-endef
-
-$(eval $(call Py3Package,python3-six))
-$(eval $(call BuildPackage,python3-six))