summaryrefslogtreecommitdiff
path: root/python3-schema/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'python3-schema/Makefile')
-rw-r--r--python3-schema/Makefile25
1 files changed, 0 insertions, 25 deletions
diff --git a/python3-schema/Makefile b/python3-schema/Makefile
deleted file mode 100644
index fd3811a..0000000
--- a/python3-schema/Makefile
+++ /dev/null
@@ -1,25 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python3-schema
-PKG_VERSION:=0.7.2
-PKG_RELEASE:=1
-PKG_SOURCE_URL:=https://github.com/keleshev/schema/archive/v$(PKG_VERSION)/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MDSUM:=d3f3ebab4939b18ea299f63fe64ce7f9
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-PKG_BUILD_DIR:=$(BUILD_DIR)/schema-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-$(call include_mk, python3-package.mk)
-
-define Package/$(PKG_NAME)
- TITLE:=Schema validation just got Pythonic
- DEPENDS:=+python3
-endef
-
-define Build/Compile
- $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
-endef
-
-$(eval $(call Py3Package,$(PKG_NAME)))
-$(eval $(call BuildPackage,$(PKG_NAME)))