summaryrefslogtreecommitdiff
path: root/python3-requests/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'python3-requests/Makefile')
-rw-r--r--python3-requests/Makefile38
1 files changed, 0 insertions, 38 deletions
diff --git a/python3-requests/Makefile b/python3-requests/Makefile
deleted file mode 100644
index f7a97ee..0000000
--- a/python3-requests/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python3-requests
-PKG_VERSION:=2.19.1
-PKG_RELEASE:=2
-
-PKG_SOURCE:=requests-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://pypi.python.org/packages/source/r/requests/
-PKG_MD5SUM:=6c1a31afec9d614e2e71a91ee6ca2878
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/requests-$(PKG_VERSION)
-PKG_BUILD_DEPENDS:=python3-setuptools
-
-include $(INCLUDE_DIR)/package.mk
-$(call include_mk, python3-package.mk)
-
-define Package/python3-requests
- SUBMENU:=Python
- SECTION:=lang
- CATEGORY:=Languages
- TITLE:=Python HTTP for Humans.
- URL:=http://python-requests.org
- DEPENDS:=+python3 +python3-chardet +python3-idna +python3-urllib3 +python3-certifi
-endef
-
-define Package/python3-requests/description
- Python HTTP for Humans.
-endef
-
-define Build/Compile
- $(call Build/Compile/Py3Mod,, \
- install --root="$(PKG_INSTALL_DIR)" --prefix="/usr" \
- --single-version-externally-managed \
- )
-endef
-
-$(eval $(call Py3Package,python3-requests))
-$(eval $(call BuildPackage,python3-requests))