summaryrefslogtreecommitdiff
path: root/python3-pyserial/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'python3-pyserial/Makefile')
-rw-r--r--python3-pyserial/Makefile36
1 files changed, 0 insertions, 36 deletions
diff --git a/python3-pyserial/Makefile b/python3-pyserial/Makefile
deleted file mode 100644
index d1d8aaf..0000000
--- a/python3-pyserial/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python3-pyserial
-PKG_VERSION:=3.4
-PKG_RELEASE:=1
-
-PKG_SOURCE:=pyserial-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://pypi.python.org/packages/source/p/pyserial/
-PKG_MD5SUM:=ed6183b15519a0ae96675e9c3330c69b
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/pyserial-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-$(call include_mk, python3-package.mk)
-
-define Package/python3-pyserial
- SUBMENU:=Python
- SECTION:=lang
- CATEGORY:=Languages
- TITLE:=Python Serial Port Extension
- URL:=http://pyserial.sourceforge.net/
- DEPENDS:=+python3
-endef
-
-define Package/python3-pyserial/description
- Python Serial Port Extension
-endef
-
-define Build/Compile
- $(call Build/Compile/Py3Mod,, \
- install --root="$(PKG_INSTALL_DIR)" --prefix="/usr" \
- )
-endef
-
-$(eval $(call Py3Package,python3-pyserial))
-$(eval $(call BuildPackage,python3-pyserial))