summaryrefslogtreecommitdiff
path: root/python3-influxdb
diff options
context:
space:
mode:
Diffstat (limited to 'python3-influxdb')
-rw-r--r--python3-influxdb/Makefile22
-rwxr-xr-xpython3-influxdb/files/bch9
2 files changed, 31 insertions, 0 deletions
diff --git a/python3-influxdb/Makefile b/python3-influxdb/Makefile
new file mode 100644
index 0000000..7cdd0cb
--- /dev/null
+++ b/python3-influxdb/Makefile
@@ -0,0 +1,22 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python3-influxdb
+PKG_RELEASE:=1
+PKG_SOURCE_URL:=https://github.com/influxdata/influxdb-python.git
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+
+include $(TOPDIR)/package/autopkg-tag.mk
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/$(PKG_NAME)
+ TITLE:=Python client for InfluxDB
+ DEPENDS:=+python3
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))
diff --git a/python3-influxdb/files/bch b/python3-influxdb/files/bch
new file mode 100755
index 0000000..a473b30
--- /dev/null
+++ b/python3-influxdb/files/bch
@@ -0,0 +1,9 @@
+#!/usr/bin/python3.6
+import bch
+import sys
+from pkg_resources import load_entry_point
+
+if __name__ == '__main__':
+ sys.exit(
+ load_entry_point('bch', 'console_scripts', 'bch')()
+ )