summaryrefslogtreecommitdiff
path: root/python3-idna/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'python3-idna/Makefile')
-rw-r--r--python3-idna/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/python3-idna/Makefile b/python3-idna/Makefile
new file mode 100644
index 0000000..7fc41ff
--- /dev/null
+++ b/python3-idna/Makefile
@@ -0,0 +1,26 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python3-idna
+PKG_VERSION:=2.7
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/i/idna/
+PKG_SOURCE:=chardet-$(PKG_VERSION).tar.gz
+PKG_MDSUM:=0e5bb69018ddef1b9d95f681182be82c
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_BUILD_DIR:=$(BUILD_DIR)/idna-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/$(PKG_NAME)
+ TITLE:=Support for the Internationalised Domain Names in Applications
+ DEPENDS:=+python3
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))