summaryrefslogtreecommitdiff
path: root/python3-dateutil/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'python3-dateutil/Makefile')
-rw-r--r--python3-dateutil/Makefile37
1 files changed, 0 insertions, 37 deletions
diff --git a/python3-dateutil/Makefile b/python3-dateutil/Makefile
deleted file mode 100644
index 357590f..0000000
--- a/python3-dateutil/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python3-dateutil
-PKG_VERSION:=2.7.3
-PKG_RELEASE:=1
-
-PKG_SOURCE_URL:=https://pypi.python.org/packages/source/p/python-dateutil/
-PKG_SOURCE:=python-dateutil-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=175b7c1a3cc0cb01151eced07c61c0b8
-PKG_BUILD_DIR:=$(BUILD_DIR)/python-dateutil-$(PKG_VERSION)
-PKG_BUILD_DEPENDS:=python3-setuptools
-
-include $(INCLUDE_DIR)/package.mk
-$(call include_mk, python3-package.mk)
-
-define Package/$(PKG_NAME)
- SUBMENU:=Python
- SECTION:=lang
- CATEGORY:=Languages
- TITLE:=Python powerful extensions to datetime
- URL:=https://dateutil.readthedocs.io/en/stable/
- DEPENDS:=+python3 +python3-six
-endef
-
-define Package/$(PKG_NAME)/description
- Python powerful extensions to datetime
-endef
-
-define Build/Compile
- $(call Build/Compile/Py3Mod,, \
- install --root="$(PKG_INSTALL_DIR)" --prefix="/usr" \
- --single-version-externally-managed \
- )
-endef
-
-$(eval $(call Py3Package,$(PKG_NAME)))
-$(eval $(call BuildPackage,$(PKG_NAME)))