summaryrefslogtreecommitdiff
path: root/python-uci/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'python-uci/Makefile')
-rw-r--r--python-uci/Makefile40
1 files changed, 0 insertions, 40 deletions
diff --git a/python-uci/Makefile b/python-uci/Makefile
deleted file mode 100644
index ae5df49..0000000
--- a/python-uci/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-#
-# Copyright (C) 2018-2020 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python-uci
-PKG_VERSION:=0.9.0
-PKG_RELEASE:=$(AUTORELEASE)
-
-PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/pyuci.git
-PKG_SOURCE_BRANCH:=euci-type-improve
-
-PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>
-PKG_LICENSE:=GPL-3.0-or-later
-PKG_LICENSE_FILES:=LICENSE
-
-include $(INCLUDE_DIR)/autopkg-branch.mk
-include $(INCLUDE_DIR)/package.mk
-include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
-
-define Package/python3-uci
- SECTION:=lang
- CATEGORY:=Languages
- SUBMENU:=Python
- TITLE:=Python UCI bindings
- URL:=https://gitlab.nic.cz/turris/pyuci/
- DEPENDS:=+python3-light +libuci
-endef
-
-define Package/python3-uci/description
- Python3 bindings for Unified Configuration Interface.
-endef
-
-$(eval $(call Py3Package,python3-uci))
-$(eval $(call BuildPackage,python3-uci))
-$(eval $(call BuildPackage,python3-uci-src))