summaryrefslogtreecommitdiff
path: root/python-schema
diff options
context:
space:
mode:
Diffstat (limited to 'python-schema')
-rw-r--r--python-schema/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/python-schema/Makefile b/python-schema/Makefile
new file mode 100644
index 0000000..6a8fc17
--- /dev/null
+++ b/python-schema/Makefile
@@ -0,0 +1,35 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-schema
+PKG_VERSION:=0.7.2
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=https://codeload.github.com/keleshev/schema/tar.gz/v$(PKG_VERSION)?
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_HASH:=df35c5ecf00f890f6c4780007478c72403730641c83392bae97d4f41f1172805
+PKG_BUILD_DIR:=$(BUILD_DIR)/schema-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-schema
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ URL:=https://github.com/keleshev/schema
+ TITLE:=python3-schema
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-schema/description
+ Schema validation just got Pythonic
+endef
+
+$(eval $(call Py3Package,python3-schema))
+$(eval $(call BuildPackage,python3-schema))
+$(eval $(call BuildPackage,python3-schema-src))