summaryrefslogtreecommitdiff
path: root/python-intelhex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'python-intelhex/Makefile')
-rw-r--r--python-intelhex/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/python-intelhex/Makefile b/python-intelhex/Makefile
new file mode 100644
index 0000000..93506a6
--- /dev/null
+++ b/python-intelhex/Makefile
@@ -0,0 +1,38 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-intelhex
+PKG_VERSION:=2.2.1
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/i/intelhex/
+PKG_SOURCE:=intelhex-$(PKG_VERSION).tar.gz
+PKG_HASH:=009d8511e0d50639230c39af9607deee771cf026f67ef7507a8c3fd4fa927832
+PKG_LICENSE:=MIT
+PKG_BUILD_DIR:=$(BUILD_DIR)/intelhex-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-intelhex
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ URL:=https://github.com/bialix/intelhex
+ TITLE:=python3-intelhex
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-intelhex/description
+ This work implements an intelhex Python library to read, write, create from
+ scratch and manipulate data from Intel HEX file format.
+endef
+
+$(eval $(call Py3Package,python3-intelhex))
+$(eval $(call BuildPackage,python3-intelhex))
+$(eval $(call BuildPackage,python3-intelhex-src))