summaryrefslogtreecommitdiff
path: root/personal-pkgs-repo
diff options
context:
space:
mode:
Diffstat (limited to 'personal-pkgs-repo')
-rw-r--r--personal-pkgs-repo/Makefile15
-rw-r--r--personal-pkgs-repo/files/updater.lua2
2 files changed, 11 insertions, 6 deletions
diff --git a/personal-pkgs-repo/Makefile b/personal-pkgs-repo/Makefile
index 2c28564..cb02c69 100644
--- a/personal-pkgs-repo/Makefile
+++ b/personal-pkgs-repo/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=personal-pkgs-repo
-PKG_VERSION:=1.3
+PKG_VERSION:=1.2
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
@@ -35,16 +35,21 @@ define Package/$(PKG_NAME)/install
echo ' personal ' >$(1)/etc/updater/opkg-ignore/personal-pkgs
endef
-BOARD=turris
-ifeq ($(CONFIG_TARGET_mvebu_Turris-Omnia),y)
-BOARD=omnia
+BOARD:=unknown
+ifeq ($(CONFIG_TARGET_PROFILE),"DEVICE_turris-omnia")
+ BOARD:=omnia
endif
+ifeq ($(CONFIG_TARGET_PROFILE),"TURRIS")
+ BOARD:=turris
+endif
+ifeq ($(CONFIG_TARGET_PROFILE),"DEVICE_cznic-mox")
+ BOARD:=mox
define Package/$(PKG_NAME)/postinst
#!/bin/sh
feedsfile="$$IPKG_INSTROOT/etc/opkg/customfeeds.conf"
sed -i '/^src\/gz personal/d' "$$feedsfile"
-echo "src/gz personal https://cynerd.cz/repo/turris3x/$(BOARD)" >> "$$feedsfile"
+echo "src/gz personal https://cynerd.cz/repo/openwrt/$(BOARD)" >> "$$feedsfile"
endef
define Package/$(PKG_NAME)/prerm
diff --git a/personal-pkgs-repo/files/updater.lua b/personal-pkgs-repo/files/updater.lua
index 2bf7636..859c780 100644
--- a/personal-pkgs-repo/files/updater.lua
+++ b/personal-pkgs-repo/files/updater.lua
@@ -7,7 +7,7 @@ else
DIE("Unsupported board!")
end
-Repository("personal-pkgs", "https://cynerd.cz/repo/turris3x/" .. board, {
+Repository("personal-pkgs", "https://cynerd.cz/repo/openwrt/" .. board, {
pubkey = "file:///etc/updater/keys/personal-pkgs.pub",
ocsp = false
})