summaryrefslogtreecommitdiff
path: root/node-red
diff options
context:
space:
mode:
Diffstat (limited to 'node-red')
-rw-r--r--node-red/Makefile39
1 files changed, 0 insertions, 39 deletions
diff --git a/node-red/Makefile b/node-red/Makefile
deleted file mode 100644
index f979e09..0000000
--- a/node-red/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-#
-## Copyright (C) 2016-2017 CZ.NIC z.s.p.o. (http://www.nic.cz/)
-#
-## This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-# #
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=node-red
-PKG_RELEASE:=1
-PKG_SOURCE_URL:=https://github.com/node-red/node-red.git
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-PKG_BUILD_DEPENDS:=node/host
-
-include $(TOPDIR)/package/autopkg-tag.mk
-include $(INCLUDE_DIR)/package.mk
-
-define Package/$(PKG_NAME)
- TITLE:=A visual tool for wiring the Internet of Things
- DEPENDS:=+node
-endef
-
-EXTRA_LDFLAGS="-L$(TOOLCHAIN_DIR)/lib/ -Wl,-rpath-link $(TOOLCHAIN_DIR)/lib/" \
-
-define Build/Compile
- $(MAKE_FLAGS) \
- npm_config_arch=$(CONFIG_ARCH) \
- npm_config_nodedir=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/ \
- npm_config_cache=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/npm-cache \
- PREFIX="$(PKG_INSTALL_DIR)/usr/" \
- $(STAGING_DIR)/host/bin/npm install -g $(PKG_BUILD_DIR)
-endef
-
-define Package/$(PKG_NAME)/install
- $(CP) $(PKG_INSTALL_DIR)/usr $(1)/usr
-endef
-
-$(eval $(call BuildPackage,$(PKG_NAME)))