summaryrefslogtreecommitdiff
path: root/click-log
diff options
context:
space:
mode:
Diffstat (limited to 'click-log')
-rw-r--r--click-log/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/click-log/Makefile b/click-log/Makefile
new file mode 100644
index 0000000..76c8507
--- /dev/null
+++ b/click-log/Makefile
@@ -0,0 +1,22 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=click-log
+PKG_RELEASE:=1
+PKG_SOURCE_URL:=https://github.com/click-contrib/click-log.git
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+
+include $(TOPDIR)/package/autopkg-tag.mk
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/$(PKG_NAME)
+ TITLE:=Simple and beautiful logging for click applications
+ DEPENDS:=+python3 +click
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))