summaryrefslogtreecommitdiff
path: root/bigclown-gateway/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'bigclown-gateway/Makefile')
-rw-r--r--bigclown-gateway/Makefile36
1 files changed, 0 insertions, 36 deletions
diff --git a/bigclown-gateway/Makefile b/bigclown-gateway/Makefile
deleted file mode 100644
index 031c315..0000000
--- a/bigclown-gateway/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=bigclown-gateway
-PKG_RELEASE:=2
-PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-gateway.git
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-
-include $(TOPDIR)/package/autopkg-tag.mk
-include $(INCLUDE_DIR)/package.mk
-$(call include_mk, python3-package.mk)
-
-define Package/$(PKG_NAME)
- TITLE:=BigCLown gateway
- DEPENDS:=+python3 +mosquitto +mosquitto-client +kmod-usb-serial-ftdi +kmod-usb-acm +python3-paho-mqtt +python3-pyyaml +python3-pyserial +python3-simplejson
-endef
-
-define Py3Package/$(PKG_NAME)/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) ./files/bcg $(1)/usr/bin/bcg
- $(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_CONF) ./files/config $(1)/etc/config/bigclown-gateway
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/init $(1)/etc/init.d/bigclown-gateway
-endef
-
-define Package/$(PKG_NAME)/conffiles
-/etc/config/bigclown-gateway
-endef
-
-define Build/Compile
- sed -i 's/@@VERSION@@/$(PKG_VERSION)/' "$(PKG_BUILD_DIR)/setup.py"
- $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
-endef
-
-$(eval $(call Py3Package,$(PKG_NAME)))
-$(eval $(call BuildPackage,$(PKG_NAME)))