summaryrefslogtreecommitdiff
path: root/autopkg-common.mk
diff options
context:
space:
mode:
Diffstat (limited to 'autopkg-common.mk')
-rw-r--r--autopkg-common.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/autopkg-common.mk b/autopkg-common.mk
index 73cff51..c539e1a 100644
--- a/autopkg-common.mk
+++ b/autopkg-common.mk
@@ -13,12 +13,11 @@ TMP_REPO_PATH=$(DL_DIR)/autopkg/$(PKG_NAME)
GIT_ARGS=--git-dir='$(TMP_REPO_PATH)' --bare
# Clone/update git history to bare repository
-# TODO it is possible that this won't fetch when there is force push to repository
$(shell \
if [ ! -d "$(TMP_REPO_PATH)" ]; then \
- git clone --bare "$(PKG_SOURCE_URL)" "$(TMP_REPO_PATH)"; \
+ git clone --mirror "$(PKG_SOURCE_URL)" "$(TMP_REPO_PATH)"; \
else \
- git $(GIT_ARGS) fetch --prune --prune-tags --force "$(PKG_SOURCE_URL)"; \
+ git $(GIT_ARGS) remote update origin; \
fi)