summaryrefslogtreecommitdiff
path: root/autopkg-branch.mk
diff options
context:
space:
mode:
Diffstat (limited to 'autopkg-branch.mk')
-rw-r--r--autopkg-branch.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/autopkg-branch.mk b/autopkg-branch.mk
index 871cffb..25e25e9 100644
--- a/autopkg-branch.mk
+++ b/autopkg-branch.mk
@@ -6,6 +6,9 @@ ifndef PKG_SOURCE_BRANCH
$(error You have to define PKG_SOURCE_BRANCH before pkgauto.mk include)
endif
+# Explicitly fetch branch
+$(shell git $(GIT_ARGS) fetch --prune --prune-tags --force "$(PKG_SOURCE_URL)" "$(PKG_SOURCE_BRANCH):$(PKG_SOURCE_BRANCH)")
+
PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) rev-parse "$(PKG_SOURCE_BRANCH)")
PKG_VERSION:=$(shell git $(GIT_ARGS) describe --abbrev=0 --tags "$(PKG_SOURCE_BRANCH)")