summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autopkg-branch.mk4
-rw-r--r--autopkg-tag.mk4
-rw-r--r--bigclown-control-tools/Makefile2
-rw-r--r--bigclown-gateway/Makefile2
-rw-r--r--bigclown-mqtt2influxdb/Makefile2
-rw-r--r--personal-pkgs-repo/Makefile15
-rw-r--r--personal-pkgs-repo/files/updater.lua2
-rw-r--r--shellrc/Makefile2
-rw-r--r--updater-ng/Makefile6
9 files changed, 23 insertions, 16 deletions
diff --git a/autopkg-branch.mk b/autopkg-branch.mk
index 977fed3..9b587b3 100644
--- a/autopkg-branch.mk
+++ b/autopkg-branch.mk
@@ -1,6 +1,6 @@
# Autopkg tracking given branch
AUTOPKG_VARIANT:=branch
-include $(TOPDIR)/package/autopkg-head.mk
+include $(TOPDIR)/feeds/personal/autopkg-head.mk
ifndef PKG_SOURCE_BRANCH
$(error You have to define PKG_SOURCE_BRANCH before pkgauto.mk include)
@@ -21,4 +21,4 @@ PKG_RELEASE:=$(shell git $(GIT_ARGS) rev-list --count "$(PKG_VERSION)..$(PKG_SOU
PKG_VERSION:=$(PKG_VERSION:v%=%).9999
endif
-include $(TOPDIR)/package/autopkg-tail.mk
+include $(TOPDIR)/feeds/personal/autopkg-tail.mk
diff --git a/autopkg-tag.mk b/autopkg-tag.mk
index 140c1c6..9b80418 100644
--- a/autopkg-tag.mk
+++ b/autopkg-tag.mk
@@ -1,8 +1,8 @@
# Autopkg tracking latest version tag
AUTOPKG_VARIANT:=tag
-include $(TOPDIR)/package/autopkg-head.mk
+include $(TOPDIR)/feeds/personal/autopkg-head.mk
PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) tag | grep '^v' | sort -V | tail -1)
PKG_VERSION:=$(subst v%,%,$(PKG_SOURCE_VERSION))
-include $(TOPDIR)/package/autopkg-tail.mk
+include $(TOPDIR)/feeds/personal/autopkg-tail.mk
diff --git a/bigclown-control-tools/Makefile b/bigclown-control-tools/Makefile
index 12f5495..e1decb7 100644
--- a/bigclown-control-tools/Makefile
+++ b/bigclown-control-tools/Makefile
@@ -5,7 +5,7 @@ PKG_RELEASE:=3
PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-control-tool.git
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-include $(TOPDIR)/package/autopkg-tag.mk
+include $(TOPDIR)/feeds/personal/autopkg-tag.mk
include $(INCLUDE_DIR)/package.mk
$(call include_mk, python3-package.mk)
diff --git a/bigclown-gateway/Makefile b/bigclown-gateway/Makefile
index 031c315..9cfaf3e 100644
--- a/bigclown-gateway/Makefile
+++ b/bigclown-gateway/Makefile
@@ -5,7 +5,7 @@ PKG_RELEASE:=2
PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-gateway.git
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-include $(TOPDIR)/package/autopkg-tag.mk
+include $(TOPDIR)/feeds/personal/autopkg-tag.mk
include $(INCLUDE_DIR)/package.mk
$(call include_mk, python3-package.mk)
diff --git a/bigclown-mqtt2influxdb/Makefile b/bigclown-mqtt2influxdb/Makefile
index c77bbbe..5e6f0d2 100644
--- a/bigclown-mqtt2influxdb/Makefile
+++ b/bigclown-mqtt2influxdb/Makefile
@@ -5,7 +5,7 @@ PKG_RELEASE:=3
PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-mqtt2influxdb.git
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-include $(TOPDIR)/package/autopkg-tag.mk
+include $(TOPDIR)/feeds/personal/autopkg-tag.mk
include $(INCLUDE_DIR)/package.mk
$(call include_mk, python3-package.mk)
diff --git a/personal-pkgs-repo/Makefile b/personal-pkgs-repo/Makefile
index 2c28564..cb02c69 100644
--- a/personal-pkgs-repo/Makefile
+++ b/personal-pkgs-repo/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=personal-pkgs-repo
-PKG_VERSION:=1.3
+PKG_VERSION:=1.2
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
@@ -35,16 +35,21 @@ define Package/$(PKG_NAME)/install
echo ' personal ' >$(1)/etc/updater/opkg-ignore/personal-pkgs
endef
-BOARD=turris
-ifeq ($(CONFIG_TARGET_mvebu_Turris-Omnia),y)
-BOARD=omnia
+BOARD:=unknown
+ifeq ($(CONFIG_TARGET_PROFILE),"DEVICE_turris-omnia")
+ BOARD:=omnia
endif
+ifeq ($(CONFIG_TARGET_PROFILE),"TURRIS")
+ BOARD:=turris
+endif
+ifeq ($(CONFIG_TARGET_PROFILE),"DEVICE_cznic-mox")
+ BOARD:=mox
define Package/$(PKG_NAME)/postinst
#!/bin/sh
feedsfile="$$IPKG_INSTROOT/etc/opkg/customfeeds.conf"
sed -i '/^src\/gz personal/d' "$$feedsfile"
-echo "src/gz personal https://cynerd.cz/repo/turris3x/$(BOARD)" >> "$$feedsfile"
+echo "src/gz personal https://cynerd.cz/repo/openwrt/$(BOARD)" >> "$$feedsfile"
endef
define Package/$(PKG_NAME)/prerm
diff --git a/personal-pkgs-repo/files/updater.lua b/personal-pkgs-repo/files/updater.lua
index 2bf7636..859c780 100644
--- a/personal-pkgs-repo/files/updater.lua
+++ b/personal-pkgs-repo/files/updater.lua
@@ -7,7 +7,7 @@ else
DIE("Unsupported board!")
end
-Repository("personal-pkgs", "https://cynerd.cz/repo/turris3x/" .. board, {
+Repository("personal-pkgs", "https://cynerd.cz/repo/openwrt/" .. board, {
pubkey = "file:///etc/updater/keys/personal-pkgs.pub",
ocsp = false
})
diff --git a/shellrc/Makefile b/shellrc/Makefile
index 034e047..55f7dcb 100644
--- a/shellrc/Makefile
+++ b/shellrc/Makefile
@@ -12,7 +12,7 @@ PKG_RELEASE:=1
PKG_SOURCE_URL:=https://git.cynerd.cz/shellrc
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-include $(TOPDIR)/package/autopkg-tag.mk
+include $(TOPDIR)/feeds/personal/autopkg-tag.mk
include $(INCLUDE_DIR)/package.mk
define Package/$(PKG_NAME)
diff --git a/updater-ng/Makefile b/updater-ng/Makefile
index 257ed8c..56967b6 100644
--- a/updater-ng/Makefile
+++ b/updater-ng/Makefile
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=updater-ng
PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater.git
-PKG_SOURCE_BRANCH:=master
+PKG_SOURCE_BRANCH:=opkg-wrapper-ignore
PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
HOST_BUILD_DEPENDS:=curl/host libevent2/host lua/host
PKG_BUILD_DEPENDS:=busybox
-include $(TOPDIR)/package/autopkg-branch.mk
+include $(TOPDIR)/feeds/personal/autopkg-branch.mk
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
$(call include_mk, python3-package.mk)
@@ -166,6 +166,8 @@ define Package/$(PKG_NAME)-opkg/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/localrepo/content2localrepo $(1)/usr/share/updater/opkg-content2localrepo.sh
$(INSTALL_DIR) $(1)/etc/updater/conf.d
$(INSTALL_CONF) $(PKG_BUILD_DIR)/src/opkg-wrapper/opkg.lua $(1)/etc/updater/conf.d/opkg.lua
+ $(INSTALL_DIR) $(1)/etc/updater/opkg-ignore
+ touch $(1)/etc/updater/opkg-ignore/.keep
endef
# We are calling migration to localrepo from updater-ng-opkg package posinst as