summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--python-contextlib2/Makefile35
-rw-r--r--python-schema/Makefile2
2 files changed, 36 insertions, 1 deletions
diff --git a/python-contextlib2/Makefile b/python-contextlib2/Makefile
new file mode 100644
index 0000000..36b8b8d
--- /dev/null
+++ b/python-contextlib2/Makefile
@@ -0,0 +1,35 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-contextlib2
+PKG_VERSION:=0.5.5
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/c/contextlib2/
+PKG_SOURCE:=contextlib2-$(PKG_VERSION).tar.gz
+PKG_HASH:=509f9419ee91cdd00ba34443217d5ca51f5a364a404e1dce9e8979cea969ca48
+PKG_BUILD_DIR:=$(BUILD_DIR)/contextlib2-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+define Package/python3-contextlib2
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ URL:=http://contextlib2.readthedocs.org
+ TITLE:=python3-contextlib2
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python-contextlib2/description
+ contextlib2 is a backport of the standard library’s contextlib module to earlier Python versions.
+endef
+
+$(eval $(call Py3Package,python3-contextlib2))
+$(eval $(call BuildPackage,python3-contextlib2))
+$(eval $(call BuildPackage,python3-contextlib2-src))
diff --git a/python-schema/Makefile b/python-schema/Makefile
index c6e4777..01e28c9 100644
--- a/python-schema/Makefile
+++ b/python-schema/Makefile
@@ -22,7 +22,7 @@ define Package/python3-schema
SUBMENU:=Python
URL:=https://github.com/keleshev/schema
TITLE:=python3-schema
- DEPENDS:=+python3-light
+ DEPENDS:=+python3-light +python3-contextlib2
VARIANT:=python3
endef