summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--updater-ng/patches/configure.ac-fix-check-for-busybox-when-cross-compil.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/updater-ng/patches/configure.ac-fix-check-for-busybox-when-cross-compil.patch b/updater-ng/patches/configure.ac-fix-check-for-busybox-when-cross-compil.patch
new file mode 100644
index 0000000..0424f0e
--- /dev/null
+++ b/updater-ng/patches/configure.ac-fix-check-for-busybox-when-cross-compil.patch
@@ -0,0 +1,31 @@
+From 1048eccde0342f5aa3133623f9cafbfa92eaf039 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
+Date: Thu, 21 May 2020 21:13:37 +0200
+Subject: [PATCH] configure.ac: fix check for busybox when cross compiling
+
+AC_CHECK_FILE works only if cross compilation is not performed. The
+reason is that it tries to check for existence of file on native system.
+
+We want check if argument is file so implement check doing exactly that
+with plain test.
+---
+ configure.ac | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index e384eae3..aec813cb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -18,7 +18,8 @@ AM_CONDITIONAL([BUSYBOX_EMBED], [test -n "$with_embed_busybox"])
+ AC_SUBST([BUSYBOX_EMBED], [$with_embed_busybox])
+ AS_IF([test -n "$with_embed_busybox"],
+ [
+- AC_CHECK_FILE([$with_embed_busybox],,[AC_MSG_ERROR([Invalid argument for --with-embed-busybox])])
++ AS_IF([test -f "$with_embed_busybox"],,
++ [AC_MSG_ERROR([Invalid argument for --with-embed-busybox])])
+ AC_DEFINE_UNQUOTED([BUSYBOX_EMBED], [$with_embed_busybox], [Embded Busybox])
+ ])
+
+--
+2.26.2
+