summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--bigclown-firmware-tool/Makefile16
-rw-r--r--personal-pkgs-repo/Makefile2
-rw-r--r--python-intelhex/Makefile2
3 files changed, 10 insertions, 10 deletions
diff --git a/bigclown-firmware-tool/Makefile b/bigclown-firmware-tool/Makefile
index 9cbfcb3..0172b0d 100644
--- a/bigclown-firmware-tool/Makefile
+++ b/bigclown-firmware-tool/Makefile
@@ -16,7 +16,7 @@ PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
PKG_BUILD_DIR:=$(BUILD_DIR)/bch-firmware-tool-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
-include ../../../lang/python/python3-package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
define Package/$(PKG_NAME)
SECTION:=utils
@@ -26,13 +26,13 @@ define Package/$(PKG_NAME)
TITLE:=BigCLown firmware tool
DEPENDS:= \
+python3-appdirs \
- +python3-pyserial \
- +python3-colorama \
- +python3-yaml \
- +python3-schema \
- +python3-requests \
- +python3-click \
- python3-intelhex
+ +python3-pyserial \
+ +python3-colorama \
+ +python3-yaml \
+ +python3-schema \
+ +python3-requests \
+ +python3-click \
+ python3-intelhex
endef
define Build/Compile
diff --git a/personal-pkgs-repo/Makefile b/personal-pkgs-repo/Makefile
index 35186f7..14be668 100644
--- a/personal-pkgs-repo/Makefile
+++ b/personal-pkgs-repo/Makefile
@@ -15,7 +15,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
include $(INCLUDE_DIR)/package.mk
define Package/$(PKG_NAME)
- TITLE:=Package with repository key and meta dependencies
+ TITLE:=Package with repository key and meta dependencies
endef
define Package/$(PKG_NAME)/install
diff --git a/python-intelhex/Makefile b/python-intelhex/Makefile
index 93506a6..bb4ed33 100644
--- a/python-intelhex/Makefile
+++ b/python-intelhex/Makefile
@@ -16,7 +16,7 @@ PKG_LICENSE:=MIT
PKG_BUILD_DIR:=$(BUILD_DIR)/intelhex-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
-include ../python3-package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
define Package/python3-intelhex
SECTION:=lang