summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--personal-pkgs-repo/Makefile2
-rw-r--r--personal-pkgs-repo/files/updater.lua2
-rw-r--r--shellrc/Makefile18
3 files changed, 4 insertions, 18 deletions
diff --git a/personal-pkgs-repo/Makefile b/personal-pkgs-repo/Makefile
index 0c4ce70..df91bbe 100644
--- a/personal-pkgs-repo/Makefile
+++ b/personal-pkgs-repo/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=personal-pkgs-repo
-PKG_VERSION:=1.4.8
+PKG_VERSION:=1.4.9
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
diff --git a/personal-pkgs-repo/files/updater.lua b/personal-pkgs-repo/files/updater.lua
index ca5dd0f..a14e06a 100644
--- a/personal-pkgs-repo/files/updater.lua
+++ b/personal-pkgs-repo/files/updater.lua
@@ -52,7 +52,7 @@ if tools then
Install("grep", "coreutils-sha256sum")
Install("iperf", "iperf3")
Install("sysstat", "strace", "gdbserver")
- Install("shellrc-zsh", "shellrc-ash")
+ Install("shellrc-zsh")
end
if vpn then
Install("luci-app-openvpn", "openvpn-openssl")
diff --git a/shellrc/Makefile b/shellrc/Makefile
index 1316349..5cf70a9 100644
--- a/shellrc/Makefile
+++ b/shellrc/Makefile
@@ -1,5 +1,5 @@
#
-## Copyright (C) 2018 Karel Kočí
+## Copyright (C) 2018-2019 Karel Kočí
#
## This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -29,14 +29,7 @@ define Package/$(PKG_NAME)-zsh
DEPENDS:=+$(PKG_NAME) +zsh
endef
-define Package/$(PKG_NAME)-ash
- TITLE:=Shell initialization files ash specific
- DEPENDS:=+$(PKG_NAME) +busybox
-endef
-
-define Build/Compile
- true
-endef
+Build/Compile:=:
define Package/$(PKG_NAME)/install
$(PKG_BUILD_DIR)/install --prefix "$(1)"
@@ -50,13 +43,6 @@ define Package/$(PKG_NAME)-zsh/install
$(PKG_BUILD_DIR)/install --prefix "$(1)" --zsh --no-base
endef
-define Package/$(PKG_NAME)-ash/install
- true
- # TODO
- #$(PKG_BUILD_DIR)/install --prefix "$(1)" --ash --no-base
-endef
-
$(eval $(call BuildPackage,$(PKG_NAME)))
$(eval $(call BuildPackage,$(PKG_NAME)-bash))
$(eval $(call BuildPackage,$(PKG_NAME)-zsh))
-$(eval $(call BuildPackage,$(PKG_NAME)-ash))