summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autopkg-head.mk4
-rw-r--r--shellrc/Makefile3
2 files changed, 5 insertions, 2 deletions
diff --git a/autopkg-head.mk b/autopkg-head.mk
index 115e1ae..a61c964 100644
--- a/autopkg-head.mk
+++ b/autopkg-head.mk
@@ -13,9 +13,9 @@ TMP_REPO_PATH=$(DL_DIR)/autopkg/$(PKG_NAME)
GIT_ARGS=--git-dir='$(TMP_REPO_PATH)' --bare
# Clone/update git history to bare repository
-$(shell \
+$(info $(shell \
if [ ! -d "$(TMP_REPO_PATH)" ]; then \
git clone --mirror "$(PKG_SOURCE_URL)" "$(TMP_REPO_PATH)"; \
else \
git $(GIT_ARGS) remote update origin; \
- fi)
+ fi))
diff --git a/shellrc/Makefile b/shellrc/Makefile
index 1c6c5fd..55f7dcb 100644
--- a/shellrc/Makefile
+++ b/shellrc/Makefile
@@ -57,3 +57,6 @@ define Package/$(PKG_NAME)-ash/install
endef
$(eval $(call BuildPackage,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)-bash))
+$(eval $(call BuildPackage,$(PKG_NAME)-zsh))
+$(eval $(call BuildPackage,$(PKG_NAME)-ash))