summaryrefslogtreecommitdiff
path: root/updater-ng
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-08-30 14:27:58 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-08-30 14:31:08 +0200
commitea39800cfac6469212013b2c459f54c3da64c613 (patch)
treedad4e3829389f15158b72abb0bc9a9f97540122a /updater-ng
parent1f0b161ecc355bb9cd2d06a3bbc1e85513298e63 (diff)
parent1a029f1092cb02ba3a2535e6342b7873ae71d18b (diff)
downloadopenwrt-personal-pkgs-ea39800cfac6469212013b2c459f54c3da64c613.tar.gz
openwrt-personal-pkgs-ea39800cfac6469212013b2c459f54c3da64c613.tar.bz2
openwrt-personal-pkgs-ea39800cfac6469212013b2c459f54c3da64c613.zip
Merge branch 'master' into turris3x
Diffstat (limited to 'updater-ng')
-rw-r--r--updater-ng/Makefile37
1 files changed, 7 insertions, 30 deletions
diff --git a/updater-ng/Makefile b/updater-ng/Makefile
index 7382529..257ed8c 100644
--- a/updater-ng/Makefile
+++ b/updater-ng/Makefile
@@ -17,7 +17,6 @@ PKG_BUILD_DEPENDS:=busybox
include $(TOPDIR)/package/autopkg-branch.mk
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
-$(call include_mk, python-package.mk)
$(call include_mk, python3-package.mk)
define Package/$(PKG_NAME)
@@ -98,8 +97,7 @@ endef
define Build/Compile
$(MAKE_VARS) $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_FLAGS) NO_DOC=1 LUA_COMPILE:=no UPDATER_VERSION:=$(PKG_VERSION) BUSYBOX_EXEC=$(STAGING_DIR)/bin/busybox-static
- $(call Build/Compile/PyMod,src/supervisor,install --prefix="/usr" --root=$(PKG_INSTALL_DIR)/py2)
- $(call Build/Compile/Py3Mod,src/supervisor,install --prefix="/usr" --root=$(PKG_INSTALL_DIR)/py3)
+ $(call Build/Compile/Py3Mod,src/supervisor,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
endef
define Host/Compile
@@ -117,11 +115,12 @@ endef
define Package/$(PKG_NAME)-supervisor
- TITLE:=Next generation updater supervisor
- DEPENDS:=+updater-ng-py3-supervisor +updater-ng +vixie-cron
+ TITLE:=Next generation updater supervisor and its library
+ DEPENDS:=+updater-ng +vixie-cron +python3-light +python3-uci +userlists +l10n_supported
+ EXTRA_DEPENDS:=userlists (>=11)
endef
-define Package/$(PKG_NAME)-supervisor/install
+define Py3Package/$(PKG_NAME)-supervisor/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/supervisor/updater-supervisor $(1)/usr/bin/
@@ -133,23 +132,9 @@ define Package/$(PKG_NAME)-supervisor/install
endef
-define Package/$(PKG_NAME)-py2-supervisor
- TITLE:=Next generation updater supervisor Python 2 library
- DEPENDS:=+updater-ng +python-light +python-uci +userlists +l10n_supported
- EXTRA_DEPENDS:=userlists (>=11)
-endef
-
-
-define Package/$(PKG_NAME)-py3-supervisor
- TITLE:=Next generation updater supervisor Python 3 library
- DEPENDS:=+updater-ng +python3-light +python3-uci +userlists +l10n_supported
- EXTRA_DEPENDS:=userlists (>=11)
-endef
-
-
define Package/$(PKG_NAME)-localrepo
TITLE:=Next generation updater local repository manager
- DEPENDS:=+python-light
+ DEPENDS:=+python3-light
endef
define Package/$(PKG_NAME)-localrepo/install
@@ -242,17 +227,9 @@ endef
# chmod +x $(1)/usr/bin/updater-wipe.sh
-PKG_INSTALL_DIR_ORIG:="$(PKG_INSTALL_DIR)"
-PKG_INSTALL_DIR:="$(PKG_INSTALL_DIR_ORIG)/py2"
-$(eval $(call PyPackage,updater-ng-py2-supervisor))
-PKG_INSTALL_DIR:="$(PKG_INSTALL_DIR_ORIG)/py3"
-$(eval $(call Py3Package,updater-ng-py3-supervisor))
-PKG_INSTALL_DIR:="$(PKG_INSTALL_DIR_ORIG)"
-
+$(eval $(call Py3Package,updater-ng-supervisor))
$(eval $(call BuildPackage,updater-ng))
$(eval $(call BuildPackage,updater-ng-supervisor))
-$(eval $(call BuildPackage,updater-ng-py2-supervisor))
-$(eval $(call BuildPackage,updater-ng-py3-supervisor))
$(eval $(call BuildPackage,updater-ng-localrepo))
$(eval $(call BuildPackage,updater-ng-opkg))
$(eval $(call BuildPackage,opkg-trans))