summaryrefslogtreecommitdiff
path: root/python3-requests
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-02-18 18:01:09 +0100
committerKarel Kočí <karel.koci@nic.cz>2019-02-18 18:01:09 +0100
commit28bd38773067b85e1bbb815460718d7648bad8fb (patch)
treee49da2539dd71172bac95e78f36c3df24503cb2d /python3-requests
parent9209c372dd43a3b0343a6f2b5625abf7124b44b4 (diff)
downloadopenwrt-personal-pkgs-28bd38773067b85e1bbb815460718d7648bad8fb.tar.gz
openwrt-personal-pkgs-28bd38773067b85e1bbb815460718d7648bad8fb.tar.bz2
openwrt-personal-pkgs-28bd38773067b85e1bbb815460718d7648bad8fb.zip
Drop bigclown as I am no longer using it on Turris 3.x
Diffstat (limited to 'python3-requests')
-rw-r--r--python3-requests/Makefile38
1 files changed, 0 insertions, 38 deletions
diff --git a/python3-requests/Makefile b/python3-requests/Makefile
deleted file mode 100644
index f7a97ee..0000000
--- a/python3-requests/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python3-requests
-PKG_VERSION:=2.19.1
-PKG_RELEASE:=2
-
-PKG_SOURCE:=requests-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://pypi.python.org/packages/source/r/requests/
-PKG_MD5SUM:=6c1a31afec9d614e2e71a91ee6ca2878
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/requests-$(PKG_VERSION)
-PKG_BUILD_DEPENDS:=python3-setuptools
-
-include $(INCLUDE_DIR)/package.mk
-$(call include_mk, python3-package.mk)
-
-define Package/python3-requests
- SUBMENU:=Python
- SECTION:=lang
- CATEGORY:=Languages
- TITLE:=Python HTTP for Humans.
- URL:=http://python-requests.org
- DEPENDS:=+python3 +python3-chardet +python3-idna +python3-urllib3 +python3-certifi
-endef
-
-define Package/python3-requests/description
- Python HTTP for Humans.
-endef
-
-define Build/Compile
- $(call Build/Compile/Py3Mod,, \
- install --root="$(PKG_INSTALL_DIR)" --prefix="/usr" \
- --single-version-externally-managed \
- )
-endef
-
-$(eval $(call Py3Package,python3-requests))
-$(eval $(call BuildPackage,python3-requests))