summaryrefslogtreecommitdiff
path: root/python3-certifi/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-09-13 15:37:27 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-09-13 15:37:27 +0200
commit5cd5bed1c32e2d3cc92b91092c3a7a317e747b3f (patch)
tree21f35fe49cf672e278aa6c92d2550dde7252a1ba /python3-certifi/Makefile
parent7957fff23ca027a9bae3ae5f66dc934cee815650 (diff)
downloadopenwrt-personal-pkgs-5cd5bed1c32e2d3cc92b91092c3a7a317e747b3f.tar.gz
openwrt-personal-pkgs-5cd5bed1c32e2d3cc92b91092c3a7a317e747b3f.tar.bz2
openwrt-personal-pkgs-5cd5bed1c32e2d3cc92b91092c3a7a317e747b3f.zip
python3-requests: add missing dependencies
Diffstat (limited to 'python3-certifi/Makefile')
-rw-r--r--python3-certifi/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/python3-certifi/Makefile b/python3-certifi/Makefile
new file mode 100644
index 0000000..e51f02f
--- /dev/null
+++ b/python3-certifi/Makefile
@@ -0,0 +1,26 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python3-certifi
+PKG_VERSION:=2018.8.24
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/c/certifi/
+PKG_SOURCE:=certifi-$(PKG_VERSION).tar.gz
+PKG_MDSUM:=c6be18cddd339c893131d992e13949c1
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_BUILD_DIR:=$(BUILD_DIR)/certifi-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/$(PKG_NAME)
+ TITLE:=Collection of Root Certificates for validating the trustworthiness of SSL certificates
+ DEPENDS:=+python3
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))