summaryrefslogtreecommitdiff
path: root/bigclown-mqtt2influxdb
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-02-18 18:01:09 +0100
committerKarel Kočí <karel.koci@nic.cz>2019-02-18 18:01:09 +0100
commit28bd38773067b85e1bbb815460718d7648bad8fb (patch)
treee49da2539dd71172bac95e78f36c3df24503cb2d /bigclown-mqtt2influxdb
parent9209c372dd43a3b0343a6f2b5625abf7124b44b4 (diff)
downloadopenwrt-personal-pkgs-28bd38773067b85e1bbb815460718d7648bad8fb.tar.gz
openwrt-personal-pkgs-28bd38773067b85e1bbb815460718d7648bad8fb.tar.bz2
openwrt-personal-pkgs-28bd38773067b85e1bbb815460718d7648bad8fb.zip
Drop bigclown as I am no longer using it on Turris 3.x
Diffstat (limited to 'bigclown-mqtt2influxdb')
-rw-r--r--bigclown-mqtt2influxdb/Makefile35
-rw-r--r--bigclown-mqtt2influxdb/files/config.yml60
-rw-r--r--bigclown-mqtt2influxdb/files/init22
-rwxr-xr-xbigclown-mqtt2influxdb/files/mqtt2influxdb9
4 files changed, 0 insertions, 126 deletions
diff --git a/bigclown-mqtt2influxdb/Makefile b/bigclown-mqtt2influxdb/Makefile
deleted file mode 100644
index c77bbbe..0000000
--- a/bigclown-mqtt2influxdb/Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=bigclown-mqtt2influxdb
-PKG_RELEASE:=3
-PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-mqtt2influxdb.git
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-
-include $(TOPDIR)/package/autopkg-tag.mk
-include $(INCLUDE_DIR)/package.mk
-$(call include_mk, python3-package.mk)
-
-define Package/$(PKG_NAME)
- TITLE:=BigCLown MQTT to Influxdb bridge
- DEPENDS:=+python3 +python3-paho-mqtt +python3-pyyaml +python3-influxdb +python3-jsonpath-ng +python3-schema
-endef
-
-define Py3Package/$(PKG_NAME)/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) ./files/mqtt2influxdb $(1)/usr/bin/mqtt2influxdb
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/init $(1)/etc/init.d/bc-mqtt2influxdb
- $(INSTALL_DATA) ./files/config.yml $(1)/etc/bc-mqtt2influxdb.yml
-endef
-
-define Package/$(PKG_NAME)/conffiles
-/etc/bc-mqtt2influxdb.yml
-endef
-
-define Build/Compile
- sed -i 's/@@VERSION@@/$(PKG_VERSION)/' "$(PKG_BUILD_DIR)/setup.py"
- $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
-endef
-
-$(eval $(call Py3Package,$(PKG_NAME)))
-$(eval $(call BuildPackage,$(PKG_NAME)))
diff --git a/bigclown-mqtt2influxdb/files/config.yml b/bigclown-mqtt2influxdb/files/config.yml
deleted file mode 100644
index 922c1b9..0000000
--- a/bigclown-mqtt2influxdb/files/config.yml
+++ /dev/null
@@ -1,60 +0,0 @@
-mqtt:
- host: 127.0.0.1
- port: 1883
-
-influxdb:
- host: 127.0.0.1
- port: 8086
- database: node
-
-points:
- - measurement: temperature
- topic: node/+/thermometer/+/temperature
- fields:
- value: $.payload
- tags:
- id: $.topic[1]
- channel: $.topic[3]
-
- - measurement: relative-humidity
- topic: node/+/hygrometer/0:4/relative-humidity
- fields:
- value: $.payload
- tags:
- id: $.topic[1]
-
- - measurement: illuminance
- topic: node/+/lux-meter/0:0/illuminance
- fields:
- value: $.payload
- tags:
- id: $.topic[1]
-
- - measurement: pressure
- topic: node/+/barometer/0:0/pressure
- fields:
- value: $.payload
- tags:
- id: $.topic[1]
-
- - measurement: co2
- topic: node/+/co2-meter/-/concentration
- fields:
- value: $.payload
- tags:
- id: $.topic[1]
-
- - measurement: voltage
- topic: node/+/battery/+/voltage
- fields:
- value: $.payload
- tags:
- id: $.topic[1]
-
- - measurement: button
- topic: node/+/push-button/+/event-count
- fields:
- value: $.payload
- tags:
- id: $.topic[1]
- channel: $.topic[3]
diff --git a/bigclown-mqtt2influxdb/files/init b/bigclown-mqtt2influxdb/files/init
deleted file mode 100644
index 5218205..0000000
--- a/bigclown-mqtt2influxdb/files/init
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/bin/sh /etc/rc.common
-
-START=99
-STOP=1
-
-USE_PROCD=1
-
-PROG=/usr/bin/mqtt2influxdb
-CONF=/etc/bc-mqtt2influxdb.yml
-
-start_service() {
- procd_open_instance
- procd_set_param respawn ${respawn_threshold:-3600} ${respawn_timeout:-5} ${respawn_retry:-5}
- procd_set_param command "$PROG" -c "$CONF"
- procd_set_param stdout 1
- procd_set_param stderr 1
- procd_close_instance
-}
-
-stop_service() {
- service_stop "$PROG"
-}
diff --git a/bigclown-mqtt2influxdb/files/mqtt2influxdb b/bigclown-mqtt2influxdb/files/mqtt2influxdb
deleted file mode 100755
index 22f9f8c..0000000
--- a/bigclown-mqtt2influxdb/files/mqtt2influxdb
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/usr/bin/python3.6
-import mqtt2influxdb
-import sys
-from pkg_resources import load_entry_point
-
-if __name__ == '__main__':
- sys.exit(
- load_entry_point('mqtt2influxdb', 'console_scripts', 'mqtt2influxdb')()
- )