summaryrefslogtreecommitdiff
path: root/autopkg-common.mk
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-08-30 11:18:06 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-08-30 11:18:06 +0200
commitd7b7793976ee2d1fac1763c224edcc7405168c57 (patch)
tree0a58b6767a306fc430816829c73cc88f6a601767 /autopkg-common.mk
parentcef196855f630f7bfd1850e0e50c8fb21bfe8891 (diff)
downloadopenwrt-personal-pkgs-d7b7793976ee2d1fac1763c224edcc7405168c57.tar.gz
openwrt-personal-pkgs-d7b7793976ee2d1fac1763c224edcc7405168c57.tar.bz2
openwrt-personal-pkgs-d7b7793976ee2d1fac1763c224edcc7405168c57.zip
Move autopkg to package so it is accessible
Diffstat (limited to 'autopkg-common.mk')
-rw-r--r--autopkg-common.mk36
1 files changed, 0 insertions, 36 deletions
diff --git a/autopkg-common.mk b/autopkg-common.mk
deleted file mode 100644
index c539e1a..0000000
--- a/autopkg-common.mk
+++ /dev/null
@@ -1,36 +0,0 @@
-ifndef AUTOPKG_VARIANT
- $(error "Don't include autopkg-common.mk directly!")
-endif
-
-ifndef PKG_NAME
-$(error You have to define PKG_NAME before pkgauto.mk include)
-endif
-ifndef PKG_SOURCE_URL
-$(error You have to define PKG_SOURCE_URL before pkgauto.mk include)
-endif
-
-TMP_REPO_PATH=$(DL_DIR)/autopkg/$(PKG_NAME)
-GIT_ARGS=--git-dir='$(TMP_REPO_PATH)' --bare
-
-# Clone/update git history to bare repository
-$(shell \
- if [ ! -d "$(TMP_REPO_PATH)" ]; then \
- git clone --mirror "$(PKG_SOURCE_URL)" "$(TMP_REPO_PATH)"; \
- else \
- git $(GIT_ARGS) remote update origin; \
- fi)
-
-
-define AUTOPKG_TAIL
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)
-
-undefine TMP_REPO_PATH
-undefine GIT_ARGS
-undefine AUTOPKG_TAIL
-
-endef