summaryrefslogtreecommitdiff
path: root/autopkg-branch.mk
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-08-26 13:48:24 +0200
committerKarel Kočí <cynerd@email.cz>2018-08-26 13:48:24 +0200
commitf0078ea2da06440e53f799ce49afcda686defa34 (patch)
tree2389110ae1a2b9ab955146cf3c8a8a43d38d1336 /autopkg-branch.mk
parent2852b61da57f46039d13ce78cdb85d31eee4732b (diff)
downloadopenwrt-personal-pkgs-f0078ea2da06440e53f799ce49afcda686defa34.tar.gz
openwrt-personal-pkgs-f0078ea2da06440e53f799ce49afcda686defa34.tar.bz2
openwrt-personal-pkgs-f0078ea2da06440e53f799ce49afcda686defa34.zip
Move explicit fetch to correct autopkg variant
Diffstat (limited to 'autopkg-branch.mk')
-rw-r--r--autopkg-branch.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/autopkg-branch.mk b/autopkg-branch.mk
index 871cffb..25e25e9 100644
--- a/autopkg-branch.mk
+++ b/autopkg-branch.mk
@@ -6,6 +6,9 @@ ifndef PKG_SOURCE_BRANCH
$(error You have to define PKG_SOURCE_BRANCH before pkgauto.mk include)
endif
+# Explicitly fetch branch
+$(shell git $(GIT_ARGS) fetch --prune --prune-tags --force "$(PKG_SOURCE_URL)" "$(PKG_SOURCE_BRANCH):$(PKG_SOURCE_BRANCH)")
+
PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) rev-parse "$(PKG_SOURCE_BRANCH)")
PKG_VERSION:=$(shell git $(GIT_ARGS) describe --abbrev=0 --tags "$(PKG_SOURCE_BRANCH)")