summaryrefslogtreecommitdiff
path: root/autopkg-branch.mk
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-08-26 13:48:24 +0200
committerKarel Kočí <cynerd@email.cz>2018-08-26 13:48:56 +0200
commitdd7d618bd8ab59b86ef64ecc64e8becf026cb5c8 (patch)
tree5ba53eb692af3953e1b1689bb0f001d02f7a5899 /autopkg-branch.mk
parent3a2aa9ec45d7bfadbb36bcb02365c1669ede7e85 (diff)
downloadopenwrt-personal-pkgs-dd7d618bd8ab59b86ef64ecc64e8becf026cb5c8.tar.gz
openwrt-personal-pkgs-dd7d618bd8ab59b86ef64ecc64e8becf026cb5c8.tar.bz2
openwrt-personal-pkgs-dd7d618bd8ab59b86ef64ecc64e8becf026cb5c8.zip
Move explicit fetch to correct autopkg variant
Diffstat (limited to 'autopkg-branch.mk')
-rw-r--r--autopkg-branch.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/autopkg-branch.mk b/autopkg-branch.mk
index 871cffb..25e25e9 100644
--- a/autopkg-branch.mk
+++ b/autopkg-branch.mk
@@ -6,6 +6,9 @@ ifndef PKG_SOURCE_BRANCH
$(error You have to define PKG_SOURCE_BRANCH before pkgauto.mk include)
endif
+# Explicitly fetch branch
+$(shell git $(GIT_ARGS) fetch --prune --prune-tags --force "$(PKG_SOURCE_URL)" "$(PKG_SOURCE_BRANCH):$(PKG_SOURCE_BRANCH)")
+
PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) rev-parse "$(PKG_SOURCE_BRANCH)")
PKG_VERSION:=$(shell git $(GIT_ARGS) describe --abbrev=0 --tags "$(PKG_SOURCE_BRANCH)")