summaryrefslogtreecommitdiff
path: root/autopkg-branch.mk
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-08-24 18:34:01 +0200
committerKarel Kočí <cynerd@email.cz>2018-08-24 18:34:01 +0200
commit041418da93ee5c4711f5cff53d0c419ae4654765 (patch)
treecd83835d9b107a9739debcf85001f0a09e93f8ac /autopkg-branch.mk
parent18c54a7a09959277b31c7671d87f94162da116af (diff)
downloadopenwrt-personal-pkgs-041418da93ee5c4711f5cff53d0c419ae4654765.tar.gz
openwrt-personal-pkgs-041418da93ee5c4711f5cff53d0c419ae4654765.tar.bz2
openwrt-personal-pkgs-041418da93ee5c4711f5cff53d0c419ae4654765.zip
Add autopkg machinery
Diffstat (limited to 'autopkg-branch.mk')
-rw-r--r--autopkg-branch.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/autopkg-branch.mk b/autopkg-branch.mk
new file mode 100644
index 0000000..871cffb
--- /dev/null
+++ b/autopkg-branch.mk
@@ -0,0 +1,24 @@
+# Autopkg tracking given branch
+AUTOPKG_VARIANT:=branch
+$(call include_mk, autopkg-common.mk)
+
+ifndef PKG_SOURCE_BRANCH
+$(error You have to define PKG_SOURCE_BRANCH before pkgauto.mk include)
+endif
+
+PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) rev-parse "$(PKG_SOURCE_BRANCH)")
+PKG_VERSION:=$(shell git $(GIT_ARGS) describe --abbrev=0 --tags "$(PKG_SOURCE_BRANCH)")
+
+ifeq ($(PKG_VERSION),)
+# Count commits since initial commit.
+PKG_RELEASE:=$(shell git $(GIT_ARGS) rev-list --count "$(PKG_SOURCE_VERSION)")
+# No previous version found (no tag) so we use 9999 instead
+PKG_VERSION:=9999
+else
+# Count commits since last version tag
+PKG_RELEASE:=$(shell git $(GIT_ARGS) rev-list --count "$(PKG_VERSION)..$(PKG_SOURCE_VERSION)")
+# .9999 is appended to not collide with possible existing package versions in repository
+PKG_VERSION:=$(PKG_VERSION:v%=%).9999
+endif
+
+$(eval $(call AUTOPKG_TAIL))