summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-09-30 08:02:09 +0200
committerKarel Kočí <cynerd@email.cz>2018-09-30 08:02:09 +0200
commite48d2180906f69009fc830b5a1f5696c6e6ab88e (patch)
treea1eca34c3106f47a9caffb60e330929a0bb3a96f
parent27ea9124b86704dda7cd5d386dd9bbbbee9d9a64 (diff)
downloadopenwrt-personal-pkgs-e48d2180906f69009fc830b5a1f5696c6e6ab88e.tar.gz
openwrt-personal-pkgs-e48d2180906f69009fc830b5a1f5696c6e6ab88e.tar.bz2
openwrt-personal-pkgs-e48d2180906f69009fc830b5a1f5696c6e6ab88e.zip
bigclown: configure init script respawn
-rw-r--r--bigclown-gateway/Makefile2
-rwxr-xr-xbigclown-gateway/files/init2
-rw-r--r--bigclown-mqtt2influxdb/Makefile2
-rw-r--r--bigclown-mqtt2influxdb/files/init2
4 files changed, 4 insertions, 4 deletions
diff --git a/bigclown-gateway/Makefile b/bigclown-gateway/Makefile
index 03b25b1..031c315 100644
--- a/bigclown-gateway/Makefile
+++ b/bigclown-gateway/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bigclown-gateway
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-gateway.git
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
diff --git a/bigclown-gateway/files/init b/bigclown-gateway/files/init
index 090cc06..02f27d1 100755
--- a/bigclown-gateway/files/init
+++ b/bigclown-gateway/files/init
@@ -39,7 +39,7 @@ start_service() {
append mqtt keyfile ' keyfile:'
procd_open_instance
- procd_set_param respawn
+ procd_set_param respawn ${respawn_threshold:-3600} ${respawn_timeout:-5} ${respawn_retry:-5}
procd_set_param command "$PROG" -c "$CONF" -W
procd_set_param stdout 1
procd_set_param stderr 1
diff --git a/bigclown-mqtt2influxdb/Makefile b/bigclown-mqtt2influxdb/Makefile
index fd606f0..c77bbbe 100644
--- a/bigclown-mqtt2influxdb/Makefile
+++ b/bigclown-mqtt2influxdb/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bigclown-mqtt2influxdb
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-mqtt2influxdb.git
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
diff --git a/bigclown-mqtt2influxdb/files/init b/bigclown-mqtt2influxdb/files/init
index 76e5d2d..5218205 100644
--- a/bigclown-mqtt2influxdb/files/init
+++ b/bigclown-mqtt2influxdb/files/init
@@ -10,7 +10,7 @@ CONF=/etc/bc-mqtt2influxdb.yml
start_service() {
procd_open_instance
- procd_set_param respawn
+ procd_set_param respawn ${respawn_threshold:-3600} ${respawn_timeout:-5} ${respawn_retry:-5}
procd_set_param command "$PROG" -c "$CONF"
procd_set_param stdout 1
procd_set_param stderr 1