summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-09-13 11:41:47 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-09-13 11:41:47 +0200
commite3325d08c8e682c10db517cdd703176380f80381 (patch)
treef16e3f620dbf9c0da0f5f5e584cf7c457e30fbba
parenta0e3148c8e1b70ea61159d8cd0c8d9692945c8d0 (diff)
downloadopenwrt-personal-pkgs-e3325d08c8e682c10db517cdd703176380f80381.tar.gz
openwrt-personal-pkgs-e3325d08c8e682c10db517cdd703176380f80381.tar.bz2
openwrt-personal-pkgs-e3325d08c8e682c10db517cdd703176380f80381.zip
Add python3-decorator
-rw-r--r--python3-decorator/Makefile24
-rw-r--r--python3-jsonpath-ng/Makefile2
2 files changed, 25 insertions, 1 deletions
diff --git a/python3-decorator/Makefile b/python3-decorator/Makefile
new file mode 100644
index 0000000..49e9d80
--- /dev/null
+++ b/python3-decorator/Makefile
@@ -0,0 +1,24 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python3-decorator
+PKG_VERSION:=4.3.1
+PKG_RELEASE:=1
+PKG_SOURCE_URL:=https://github.com/micheles/decorator/archive/$(PKG_VERSION)/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MDSUM:=b92084f8732267b9ea5bfe8887fbad14
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/$(PKG_NAME)
+ TITLE:=Schema validation just got Pythonic
+ DEPENDS:=+python3
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))
diff --git a/python3-jsonpath-ng/Makefile b/python3-jsonpath-ng/Makefile
index 445c743..78bc42a 100644
--- a/python3-jsonpath-ng/Makefile
+++ b/python3-jsonpath-ng/Makefile
@@ -15,7 +15,7 @@ $(call include_mk, python3-package.mk)
define Package/$(PKG_NAME)
TITLE:=Python composable command line utility
- DEPENDS:=+python3
+ DEPENDS:=+python3 +python3-ply +python3-six +python3-decorator
endef
define Build/Compile