summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-08-30 12:37:18 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-08-30 12:37:18 +0200
commitd83bde419809e1836983c8fead7185dfb7689b04 (patch)
treed0e0c8b746a7f24775d9d7f67ab73f2325cec7a6
parentd7b7793976ee2d1fac1763c224edcc7405168c57 (diff)
downloadopenwrt-personal-pkgs-d83bde419809e1836983c8fead7185dfb7689b04.tar.gz
openwrt-personal-pkgs-d83bde419809e1836983c8fead7185dfb7689b04.tar.bz2
openwrt-personal-pkgs-d83bde419809e1836983c8fead7185dfb7689b04.zip
autopkg: split common
-rw-r--r--personal-pkgs-repo/files/autopkg-branch.mk4
-rw-r--r--personal-pkgs-repo/files/autopkg-head.mk (renamed from personal-pkgs-repo/files/autopkg-common.mk)17
-rw-r--r--personal-pkgs-repo/files/autopkg-tag.mk4
-rw-r--r--personal-pkgs-repo/files/autopkg-tail.mk13
4 files changed, 18 insertions, 20 deletions
diff --git a/personal-pkgs-repo/files/autopkg-branch.mk b/personal-pkgs-repo/files/autopkg-branch.mk
index 871cffb..c8791cc 100644
--- a/personal-pkgs-repo/files/autopkg-branch.mk
+++ b/personal-pkgs-repo/files/autopkg-branch.mk
@@ -1,6 +1,6 @@
# Autopkg tracking given branch
AUTOPKG_VARIANT:=branch
-$(call include_mk, autopkg-common.mk)
+$(call include_mk, autopkg-head.mk)
ifndef PKG_SOURCE_BRANCH
$(error You have to define PKG_SOURCE_BRANCH before pkgauto.mk include)
@@ -21,4 +21,4 @@ PKG_RELEASE:=$(shell git $(GIT_ARGS) rev-list --count "$(PKG_VERSION)..$(PKG_SOU
PKG_VERSION:=$(PKG_VERSION:v%=%).9999
endif
-$(eval $(call AUTOPKG_TAIL))
+$(call include_mk, autopkg-tail.mk)
diff --git a/personal-pkgs-repo/files/autopkg-common.mk b/personal-pkgs-repo/files/autopkg-head.mk
index c539e1a..115e1ae 100644
--- a/personal-pkgs-repo/files/autopkg-common.mk
+++ b/personal-pkgs-repo/files/autopkg-head.mk
@@ -1,5 +1,5 @@
ifndef AUTOPKG_VARIANT
- $(error "Don't include autopkg-common.mk directly!")
+ $(error "Don't include autopkg-head.mk directly!")
endif
ifndef PKG_NAME
@@ -19,18 +19,3 @@ $(shell \
else \
git $(GIT_ARGS) remote update origin; \
fi)
-
-
-define AUTOPKG_TAIL
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)
-
-undefine TMP_REPO_PATH
-undefine GIT_ARGS
-undefine AUTOPKG_TAIL
-
-endef
diff --git a/personal-pkgs-repo/files/autopkg-tag.mk b/personal-pkgs-repo/files/autopkg-tag.mk
index 6fe08d4..077c7ad 100644
--- a/personal-pkgs-repo/files/autopkg-tag.mk
+++ b/personal-pkgs-repo/files/autopkg-tag.mk
@@ -1,8 +1,8 @@
# Autopkg tracking latest version tag
AUTOPKG_VARIANT:=tag
-$(call include_mk, autopkg-common.mk)
+$(call include_mk, autopkg-head.mk)
PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) tag | grep '^v' | sort | tail -1)
PKG_VERSION:=$(subst v%,%,$(PKG_SOURCE_VERSION))
-$(eval $(call AUTOPKG_TAIL))
+$(call include_mk, autopkg-tail.mk)
diff --git a/personal-pkgs-repo/files/autopkg-tail.mk b/personal-pkgs-repo/files/autopkg-tail.mk
new file mode 100644
index 0000000..3b6d104
--- /dev/null
+++ b/personal-pkgs-repo/files/autopkg-tail.mk
@@ -0,0 +1,13 @@
+ifndef AUTOPKG_VARIANT
+ $(error "Don't include autopkg-tail.mk directly!")
+endif
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)
+
+undefine TMP_REPO_PATH
+undefine GIT_ARGS
+undefine AUTOPKG_TAIL